glassfish
  1. glassfish
  2. GLASSFISH-13955

[508] cannot toggle between locations in Deploy Applications Screen

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      13,955
    • Tags:

      Description

      Build Used: GFV3.1 promoted build23.

      Browser Used : firefox 3.6.
      Os: Windows XP
      In the Deploy Applications or Modules, window, we cannot toggle using the
      keyboard hotkeys between the 2 radio buttons "Packaged File to be Uploaded to
      the Server",and "Local Packaged File or Airectory that is Accessible from the
      Enterprise server". The HOTKeys space bar, PageUP, PageDn, or Tab nothing works
      , and we have to use mouse to select one of the above radio buttons.
      Steps:
      Use Tab key to navigate to "APplications" node in the left side, and hit "Enter"
      Use Tab key to navigate all the way down until "Update Tool" , and then focus
      shifts to Right hand "Deploy Applications and Modules" window.

      Use Tab Key in the "Deploy Applications and Modules" window, to select the
      "Location (radio button): Packaged file to be uploaded to the server.
      Try to Select the other radio button, using the spacebar, or PageUP, PageDn
      keys. nothing seems to work, and we have to use mouse.

        Activity

        Anissa Lam added a comment -

        I looked at the deployment page and don't experience any issues you showed me.

        ---------------------------------------------------------
        1st – cannot toggle between locations radio button.

        Here is what you should do to go to the next radio button:

        1. tab to the first radio button. ( Since you are in "Radio Button", you have to
        use up and down arrows to get to the next radio button.)
        2. press the down arrow, you will be at the "Local Package... radio button".

        So, you can use up and down arrow to toggle between.

        ----------------------------------
        2nd issue you show me about not able to bring up the file browser window, you
        should use 'space bar'.
        So, go to the radio button, tab to the text field, then tab again to 'Browse'
        button. Now, press 'space bar' to bring up the file browser.
        Same for the other 2 buttons, 'Browse Files' and 'Browse Folders...'. Use the
        space bar.

        --------------------------------
        3rd issue you mentioned, about not able to select Virtual Servers.
        I cannot reproduce this.
        Once i tab into this 'selection list box', i can use up and down arrow to
        high-light the vs i want, then tab to the next thing, which is the Enable checkbox.

        -------------------------------

        I have tested all the above on my WinXP, using both Firefox and IE7 browser.

        So, sounds like i can get everything working with the keyboard. Can you try again ?

        shaline added a comment -

        I was able to select the radio buttons using the up/down arrow and also open up
        the file upload window. But was not able to get the 3rd issue working:
        I was not able to select the
        "server" virtual server using up and down arrow after tabbing to Virtual servers.

        Lowering the priority to P3.

        shaline added a comment -

        I was able to get through the issue #3, by using left/right arrow keys, and was
        able to select the Virtual server..
        So this bug can be closed, as the issue is not reproducible.

        Anissa Lam added a comment -

        Thanks for trying this out again.
        So, I am closing this as works for me.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: