Issue Details (XML | Word | Printable)

Key: GLASSFISH-13994
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Snjezana Sevo-Zenzerovic
Reporter: Snjezana Sevo-Zenzerovic
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

(UC) pkg Java API is unable to report updates if packages use variants

Created: 14/Oct/10 03:15 PM   Updated: 23/Dec/10 10:57 AM   Resolved: 23/Dec/10 10:57 AM
Component/s: update_center
Affects Version/s: 3.1
Fix Version/s: 3.1_b35

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: Sun


Issuezilla Id: 13,994
Tags: 3_1-approved
Participants: Snjezana Sevo-Zenzerovic


 Description  « Hide

Update section of Admin GUI which uses pkg Java API is unable to process and
report available updates if packages use variants - this is currently the case
for Java EE 6 SDK distributions with bundled JDK. While it has been known that
Java API does not correctly handle variants in UC 2.3u2, the expectation was
that one of provided variant files will be picked up for installation or update
during the creation of PackagePlan. However, this is not the case and
IllegalArgumentException is being thrown instead.

Full stack trace has been posted in this forum thread:

http://forums.java.net/jive/thread.jspa?messageID=482123&#482123



Snjezana Sevo-Zenzerovic added a comment - 14/Oct/10 03:21 PM

Snjezana Sevo-Zenzerovic added a comment - 21/Dec/10 01:26 PM

How bad is its impact? (Severity)
Moderate. Very bad user experience for users of Java EE 6 SDK which try to access Update section of Admin GUI due to exception.

How often does it happen? Will many users see this problem? (Frequency)
Frequent. It happens for all Java EE 6 SDK distribution users which access Update node in Admin GUI.

How much effort is required to fix it? (Cost)
Minimal effort. Fix is already available in UC 2.3u3 and fix consists of 2.3u3 Java API binary integration into GlassFish 3.1.

What is the risk of fixing it and how will the risk be mitigated? (Risk)
Minimal risk. Fix has been verified using preliminary build of UC 2.3u3 and no regressions have been observed.


Snjezana Sevo-Zenzerovic added a comment - 23/Dec/10 10:57 AM

UC 2.3u3 pkg-client.jar is integrated into GlassFish 3.1 workspace and that integration addresses this issue.