glassfish
  1. glassfish
  2. GLASSFISH-14080

[PERF] Implement Map based caching strategy for batching ReplicationData

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b32
    • Component/s: failover
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      14,080

      Description

      Currently, the replication module performs batching by maintaining a List. This
      is useful if the POJO (the JavaObject whose serialized data is being replicated)
      provides incremental updates (like modified-attributes).

      However, if the POJOs are always fully saved (like EJBs), then we will benefit by
      using a Map like structure as opposed to a List like structure.

      This might help the current trade2 run.

        Issue Links

          Activity

          Mahesh Kannan added a comment -

          Set the target ms to ms6

          Mahesh Kannan added a comment -

          This is currently being worked on. However, no profile has so far showed that
          this is indeed the cause for regression in trade2 numbers. So marking this for
          ms7

          Mahesh Kannan added a comment -

          We now use a HashMap to avoid replicating stale data. Tested with Trade2


            People

            • Assignee:
              Mahesh Kannan
              Reporter:
              Mahesh Kannan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: