Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      This is in this morning's build, rev 41874. I create a v2.1.1 cluster and
      upgrade to 3.1 with these steps:

      http://wikis.sun.com/display/GlassFish/V3.1ClusterUpgradeExample

      Everything works, and I can access the instances in the admin GUI. When I click
      the "Stop" button to stop instance 1 and confirm with the popup, I get a 500
      response with this info:

      javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
      while attempting to process a 'command' event for 'stopInstance'.

      Will attach the server log after filing. Here's the root cause:

      Caused by: java.lang.NullPointerException
      at org.apache.catalina.connector.Response.sendRedirect(Response.java:1389)
      at org.apache.catalina.connector.Response.sendRedirect(Response.java:1333)
      at
      org.apache.catalina.connector.ResponseFacade.sendRedirect(ResponseFacade.java:528)
      at
      org.glassfish.admingui.common.handlers.CommonHandlers.redirect(CommonHandlers.java:573)
      ... 49 more

      1. server.log
        55 kB
        Bobby Bissett

        Activity

        Bobby Bissett added a comment -

        Created an attachment (id=5181)
        server log file during runtime

        adf59 added a comment -

        Same sort of behavior occurs when hitting the start button as well to restart
        the instance up again after an intial stop. The output below was shown in admin
        GUI window:

        HTTP Status 500 -

        type Exception report

        message

        descriptionThe server encountered an internal error () that prevented it from
        fulfilling this request.

        exception

        javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
        while attempting to process a 'command' event for 'startInstance'.

        root cause

        java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while
        attempting to process a 'command' event for 'startInstance'.

        root cause

        java.lang.reflect.InvocationTargetException

        root cause

        java.lang.NullPointerException

        note The full stack traces of the exception and its root causes are available in
        the GlassFish Server Open Source Edition 3.1-b25 logs.

        Anissa Lam added a comment -

        After the start/stop command, the page redirected to is not specified correctly.
        Fix checked in for nightly build 10/31.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Bobby Bissett
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: