glassfish
  1. glassfish
  2. GLASSFISH-14119

[BLOCKING] targetserver element in sun-acc.xml ignored

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b27
    • Component/s: standalone_client
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      14,119

      Description

      I am using appclient to run our tests

      We have specified target-server elements in sun-acc.xml and running the test as
      follows

      /export/appcvs/glassfish/glassfish3/glassfish/bin/appclient -classpath
      /export/appcvs/agentrepo//appclient/cartClient/cart-app-clientClient.jar -xml
      /export/appcvs/agentrepo//appclient/sun-acc.xml cart.client.CartFailoverClient

      It seems, the appclient is not picking target-server elements

        Activity

        Tim Quinn added a comment -

        It turns out that there were two separate places in the ACC that were setting
        ORB information. I had fixed one of them earlier but not the other one, which
        ran later and therefore set the naming manager's default port and host which
        overrode the load balancing.

        I have a complete fix in place in my workspace and the test scenario I described
        for Ken as not working before is working now. (sun-acc specifies two
        target-servers, only the second of them is started when the client is launched)

        I will run several more tests before I check this in but the solution is at hand.

        Apologies to Ken for earlier sending this back to him again incorrectly.

        Tim Quinn added a comment -

        Fix checked in.

        Author: tjquinn
        Date: 2010-10-28 17:08:39+0000
        New Revision: 42255

        Modified:

        trunk/v3/appclient/client/acc/src/main/java/org/glassfish/appclient/client/acc/AppClientContainerBuilder.java

        trunk/v3/appclient/client/acc/src/main/java/org/glassfish/appclient/client/acc/AppClientContainerSecurityHelper.java

        Log:
        Fix for 14119

        The ACC was incorrectly setting IIOP values in two places. I had fixed one
        place with an earlier check-in to correctly support multiple endpoints, but not
        the second place. I've now removed the redundant logic.

        Tests: QL, deployment devtests, ejb devtests (with 2 failures related to
        embedded, not ACC)

        Tim Quinn added a comment -

        Updating target milestone to b27.

        gopaljorapur added a comment -

        The issue is not fixed yet, here is the stack trace when I use sun-acc.xml

        ailoverClient ICFailover at /export/DecCVS/agentrepo//appclient
        Dec 29, 2010 3:21:09 PM com.sun.logging.LogDomains$1 log
        INFO: DTX5019: Transaction Manager is ready. Using [com.sun.enterprise.tr ansaction.jts.JavaEETransactionManagerJTSDelegate] as the delegate
        Inside IC
        javax.naming.NamingException: Lookup failed for 'cart.ejb.CartRemote' in SerialContext[targetHost=null,targetPort=null [Root exception is javax.na ming.NameNotFoundException: cart.ejb.CartRemote not found]
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialCont ext.java:561)
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialCont ext.java:491)
        at javax.naming.InitialContext.lookup(InitialContext.java:392)
        at cart.client.CartFailoverClient.runICFailoverTest(CartFailoverC lient.java:64)
        at cart.client.CartFailoverClient.main(CartFailoverClient.java:40 )
        Caused by: javax.naming.NameNotFoundException: cart.ejb.CartRemote not fo und
        at com.sun.enterprise.naming.impl.TransientContext.doLookup(Trans ientContext.java:245)
        at com.sun.enterprise.naming.impl.TransientContext.lookup(Transie ntContext.java:212)
        at com.sun.enterprise.naming.impl.SerialContextProviderImpl.looku p(SerialContextProviderImpl.java:77)
        at com.sun.enterprise.naming.impl.RemoteSerialContextProviderImpl .lookup(RemoteSerialContextProviderImpl.java:94)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccess orImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMeth odAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie.dispatchT oMethod(ReflectiveTie.java:144)
        at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie._invoke(R eflectiveTie.java:174)
        at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImp l.dispatchToServant(CorbaServerRequestDispatcherImpl.java:528)
        at com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImp l.dispatch(CorbaServerRequestDispatcherImpl.java:199)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handle RequestRequest(CorbaMessageMediatorImpl.java:1624)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handle Request(CorbaMessageMediatorImpl.java:1486)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handle Input(CorbaMessageMediatorImpl.java:990)
        at com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1 _2.callback(RequestMessage_1_2.java:214)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.handle Request(CorbaMessageMediatorImpl.java:742)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.dispat ch(CorbaMessageMediatorImpl.java:539)
        at com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.doWork (CorbaMessageMediatorImpl.java:2324)
        at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$Worker Thread.performWork(ThreadPoolImpl.java:496)
        at com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$Worker Thread.run(ThreadPoolImpl.java:537)
        Dec 29, 2010 3:21:43 PM com.sun.dft.glassfish.ipc.api.CallbackClient kill Instance

        Same test works when we use endpoints

        Tim Quinn added a comment -

        Gopal,

        What build are you using?

        And please describe exactly what you are doing to trigger this exception.

        I have just now tested with a very current workspace and with build 27, using the scenario I described in an earlier comment on this issue (using the simple deployment devtest) and the client was able to reach whichever server I left running and complete successfully.


          People

          • Assignee:
            Tim Quinn
            Reporter:
            gopaljorapur
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: