Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      14,185

      Description

      Running Glassfish 3.1-b24 both on Felix and Equinox and looking at the bundles
      in the console, there is a noticeable difference: Felix leaves a large number of
      bundles INSTALLED, while Equinox lists (almost) all of them as RESOLVED or ACTIVE.

      I don't know if this is an implementation detail or problematic at all.

      However, there are two bundles which neither Equinox nor Felix can resolve -
      here are the messages from Felix when trying to start the bundles manually:

      org.osgi.framework.BundleException: Unresolved constraint in bundle
      org.glassfish.appclient.gf-client-module [134]: Unable to resolve 134.0: missing
      requirement [134.0] package; (package=com.sun.enterprise.deployment.node)

      org.osgi.framework.BundleException: Unresolved constraint in bundle
      org.glassfish.admin.cli-optional [165]: Unable to resolve 165.0: missing
      requirement [165.0] package; (package=com.sun.enterprise.admin.servermgmt.services)

        Activity

        Richard S. Hall added a comment -

        Frameworks are free to resolve bundles when they see fit as long as it is any
        bundle is successfully resolved before allowing any classes to be loaded from it.

        Richard S. Hall added a comment -

        Sorry, that should say:

        Frameworks are free to resolve a bundle when they see fit as long as the bundle
        is successfully resolved before allowing any classes to be loaded from it.

        Sanjeeb Sahoo added a comment -

        Those two unresolved bundles won't cause any problem, but we should fix them
        never-the-less. So, I am assigning this to acc module which generates the first
        of the two bundles reported here. Tim, after addressing the gf-client-module
        bundle, please assign the issue to admin team for the second bundle.

        Tim Quinn added a comment -

        I am reassigning this to the admin team to address the second part of the issue.

        I do not see this error when I manually start the gf-client-module bundle.
        Maybe I am doing things differently than you or maybe the first part of this
        issue is no longer a problem. Can you list exactly how you manually started the
        module to trigger the error?

        In the entire module there is only one reference to a class from
        com.sun.enterprise.deployment.node. That package is in the deployment/dol
        module, which is included in the dependencies for the gf-client-module module.
        And that package is listed in the exportcontents setting for deployment/dol. So
        unless something has changed since the original issue was opened I'm not sure
        why there would be a problem.

        Sanjeeb Sahoo added a comment -

        Tim, I have recently fixed the missing package issue related to gf-client-module
        in order to address issue 14373, so you are not seeing the problem reported by
        user. However, the problem still exists for cli-optional.jar.

        Sahoo

        Tom Mueller added a comment -

        Jennifer, can you please look into what dependency is missing for the cli-
        optional.jar file?

        Jennifer Chou added a comment -

        Can you list the exact steps to start the cli-optional bundle manually, so I can
        see the 'Unresolved constraint..' error.

        Sanjeeb Sahoo added a comment -

        I am sad to know the reality. Anyway, this is how one can easily reproduce the
        issue:

        telnet localhost 6666
        g! lb -l | grep cli-optional.jar
        192|Installed |
        1|file:/space/ss141213/WS/gf/v3/publish/glassfish3/glassfish/modules/cli-optional.jar

        g! start 192
        You will see the resolution exception.

        Apply the patch shown below to fix the issue:

        ss141213@Sahoo:/space/ss141213/WS/gf/v3$ svn diff admin/server-mgmt/osgi.bundle
        Index: admin/server-mgmt/osgi.bundle
        ===================================================================
        — admin/server-mgmt/osgi.bundle (revision 42687)
        +++ admin/server-mgmt/osgi.bundle (working copy)
        @@ -41,4 +41,5 @@
        -exportcontents: \
        com.sun.enterprise.admin.servermgmt; \
        com.sun.enterprise.admin.servermgmt.pe; \
        + com.sun.enterprise.admin.servermgmt.services; \
        com.sun.enterprise.admin.servermgmt.util;
        version=$

        {project.osgi.version}
        Jennifer Chou added a comment -

        fix checked in.


          People

          • Assignee:
            Jennifer Chou
            Reporter:
            Harald Wellmann
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: