glassfish
  1. glassfish
  2. GLASSFISH-14256

System Properties: exception when clicking Instance Values for new property

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: glassfish-3.1-b25-10_21_2010.zip

      Create a cluster with one instance. Go to cluster config, System Properties
      page. Click on Add Property, fill out the fields for new property (not really
      needed to reproduce this bug) and click on Instance Values link for this new
      property. The following exception is displayed on page:

      type Exception report

      message

      descriptionThe server encountered an internal error () that prevented it from
      fulfilling this request.

      exception

      javax.servlet.ServletException: javax.el.PropertyNotFoundException: Field
      'cluster' not found in DataProvider.

      root cause

      javax.el.PropertyNotFoundException: javax.el.PropertyNotFoundException: Field
      'cluster' not found in DataProvider.

      root cause

      javax.el.PropertyNotFoundException: Field 'cluster' not found in DataProvider.

      note The full stack traces of the exception and its root causes are available in
      the GlassFish Server Open Source Edition 3.1-SNAPSHOT logs.
      GlassFish Server Open Source Edition 3.1-SNAPSHOT

        Activity

        lidiam added a comment -

        Created an attachment (id=5253)
        screenshot

        lidiam added a comment -

        Created an attachment (id=5254)
        server.log

        Jason Lee added a comment -

        Fix committed (r42497)

        lidiam added a comment -

        Verified in promoted build b43.


          People

          • Assignee:
            Jason Lee
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: