Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      14,272

      Description

      It seems dpeloyment backend is trying to use BundleDescriptor before it is
      available causing NPE in DolProvider.getModuleLibraryJars. See the attached
      stacktrace:

      [#|2010-10-27T09:22:35.390+0530|WARNING|glassfish3.1|null|_ThreadID=80;_ThreadName=telnetconsole.shell
      remote=/127.0.0.1:52218;|failed to get library jar:
      java.lang.NullPointerException
      at
      org.glassfish.javaee.core.deployment.DolProvider.getModuleLibraryJars(DolProvider.java:273)
      at
      org.glassfish.javaee.core.deployment.DolProvider.getLibraryJars(DolProvider.java:262)
      at
      com.sun.enterprise.v3.server.SnifferManagerImpl.getURIs(SnifferManagerImpl.java:261)
      at
      com.sun.enterprise.v3.server.SnifferManagerImpl.getApplicableSniffers(SnifferManagerImpl.java:199)
      at
      com.sun.enterprise.v3.server.SnifferManagerImpl.getSniffers(SnifferManagerImpl.java:147)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.setupContainerInfos(ApplicationLifecycle.java:570)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:347)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:243)
      at
      org.glassfish.osgijavaeebase.OSGiDeploymentRequest.deploy(OSGiDeploymentRequest.java:181)
      at
      org.glassfish.osgijavaeebase.OSGiDeploymentRequest.execute(OSGiDeploymentRequest.java:116)
      at
      org.glassfish.osgijavaeebase.AbstractOSGiDeployer.deploy(AbstractOSGiDeployer.java:121)
      at org.glassfish.osgijavaeebase.OSGiContainer.deploy(OSGiContainer.java:147)
      at org.glassfish.osgijavaeebase.JavaEEExtender.deploy(JavaEEExtender.java:118)
      at
      org.glassfish.osgijavaeebase.JavaEEExtender.bundleChanged(JavaEEExtender.java:103)
      at
      org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:807)
      at
      org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:729)
      at
      org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:610)
      at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:3713)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1767)
      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
      at org.apache.felix.gogo.command.Basic.start(Basic.java:758)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.felix.gogo.runtime.Reflective.method(Reflective.java:136)
      at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:82)
      at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:458)
      at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:384)
      at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
      at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
      at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
      at
      org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:79)
      at org.apache.felix.gogo.shell.Console.run(Console.java:62)
      at org.apache.felix.gogo.shell.Shell.console(Shell.java:198)
      at org.apache.felix.gogo.shell.Shell.gosh(Shell.java:124)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.felix.gogo.runtime.Reflective.method(Reflective.java:136)
      at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:82)
      at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:458)
      at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:384)
      at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
      at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
      at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
      at
      org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:79)
      at org.apache.felix.shell.remote.Shell.startGogoShell(Shell.java:108)
      at org.apache.felix.shell.remote.Shell.run(Shell.java:81)
      at java.lang.Thread.run(Thread.java:619)

      #]

      Hong has acknowledged this as a bug in email, yet I am filing this because it's
      affecting hybrid app developers. Please fix ASAP.

        Activity

        Hong Zhang added a comment -

        sahoo, I already fixed this yesterday for the osgi application. Can you try
        with the latest workspace/nightly build with the hybrid application? If the
        problem still exists, maybe the hybrid application needs some additional
        changes, please attach a simple hybrid application in that case for me to
        reproduce. thanks!

        Sanjeeb Sahoo added a comment -

        Created an attachment (id=5270)
        Simple test case. Copy it to autodeploy/bundles/ dir

        Hong Zhang added a comment -

        Thanks for attaching the test case. Yes, this was fixed by yesterday's fix
        also, the application was deployed successfully and no NPE in the server.log


          People

          • Assignee:
            Hong Zhang
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: