glassfish
  1. glassfish
  2. GLASSFISH-14283

[Blocking] System Properties: exception for standalone instance values link

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: glassfish-3.1-b26-10_26_2010.zip

      Create a standalone instance copying default-config. Go to instance's
      configuration, System Properties page. Click on Instance Values for HTTP port
      (or any other) and the following exception is printed on the screen:

      HTTP Status 500 -

      type Exception report

      message

      descriptionThe server encountered an internal error () that prevented it from
      fulfilling this request.

      exception

      javax.servlet.ServletException: javax.el.PropertyNotFoundException: Field
      'cluster' not found in DataProvider.

      root cause

      javax.el.PropertyNotFoundException: javax.el.PropertyNotFoundException: Field
      'cluster' not found in DataProvider.

      root cause

      javax.el.PropertyNotFoundException: Field 'cluster' not found in DataProvider.

      note The full stack traces of the exception and its root causes are available in
      the GlassFish Server Open Source Edition 3.1-SNAPSHOT logs.
      GlassFish Server Open Source Edition 3.1-SNAPSHOT

      The exception looks the same as in GLASSFISH-14256, even though I'm viewing
      standalone instance values here. Cannot test changing values due to this issue.
      Between this bug and GLASSFISH-14263, cannot test restart required.

        Activity

        lidiam added a comment -

        Created an attachment (id=5273)
        screenshot

        lidiam added a comment -

        Created an attachment (id=5274)
        server.log

        Jason Lee added a comment -

        Fix committed (r42511)

        lidiam added a comment -

        verified in promoted build b43


          People

          • Assignee:
            Jason Lee
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: