glassfish
  1. glassfish
  2. GLASSFISH-14311

Session Replication is broken when app is deployed through Admin Console

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b27
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      14,311

      Description

      Session replication is not working when a cluster-enabled app is deployed using
      Admin Console but works when deployed through CLI. The difference is that GUI is
      setting the property as shown:

      <application location="$

      {com.sun.aas.instanceRootURI}/applications/clusterjsp/"
      name="clusterjsp" object-type="user">
      <property name="availabilityEnabled" value="true"></property>


      where as it should be an attribute as shown:

      <application availability-enabled="true"
      location="${com.sun.aas.instanceRootURI}

      /applications/c
      lusterjsp/" name="clusterjsp" object-type="user">

        Activity

        Anissa Lam added a comment -

        Thanks for catching this.
        This is fixed in 11/1 nightly build.

        Anissa Lam added a comment -
            • Issue 14359 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Anissa Lam
            Reporter:
            arungupta
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: