glassfish
  1. glassfish
  2. GLASSFISH-14353

Log viewer: change "Records Before 0" button

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: glassfish-3.1-b27-10_31_2010.zip

      When in Log Viewer for DAS, I'm searching for some entries and get 11 results.
      I see "Records before 0" button and "Records after 11" button.

      The first button should be renamed, either to "Previous" and disbled, or
      equivalent of "Continue from the end of the file".

      Regarding the second button, I think this button would only return more results
      if server.log was updated in the meantime with entries that match the query. If
      this is the case, this button would be better called "Update results". Ideally
      there should always be "Previous" and "Next" buttons, plus optional "Update
      results". Buttons called "Records after 11" are misleading - they indicate that
      there are more records, where in fact there aren't.

        Activity

        sirajg added a comment -

        Records before 0 is not displayed. Records after "x" is displayed because the
        log viewer does not know if any more records are available at this time. If no
        records are available, and you click "Records after 'x'", then a screen
        displaying the information that no more records are available, is displayed.

        lidiam added a comment -

        Current implementation of displaying search results and "previous", "next" buttons is confusing. I searched for grizzly and see the following:

        "Records before 8" button
        "Records after 236" button
        "Log File Record Numbers 8 through 236" text between the buttons.

        At this point I think I have hundreds of results. I click on "Records before 8" button and get a page with "No items found" result and the following buttons:

        "Previous"
        "Next"

        This is inconsistent with the previous button display. Also, this page already has no results, having "Previous" is confusing. I click on "Previous" and results are displayed - the initial results are displayed, so the "Previous" button wrapped the search. This is counter intuitive and there is no reason to wrap searches (specifically since we do not notify user that we do that).

        Now I notice that the initial results page has the following text in the title of the table:

        "Log Viewer Results (6)"

        This is not something that user will see right away. It would be better to put the number of results in the text between the "previous" and "next" buttons. E.g. it could read: "Results: (6); Displaying records 8 through 236". I'll attach a screenshot.

        sirajg added a comment -

        When you search, filtered results are shown. Record numbers are not associated with the filtered result - those are actual log record numbers.

        Wrapping to top of file is a feature that has been in the log viewer for several releases.


          People

          • Assignee:
            sirajg
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: