glassfish
  1. glassfish
  2. GLASSFISH-14384

Extra character in default install directory

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.1
    • Fix Version/s: 4.0
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

      Description

      On build 26, ogs distribution, and while installing on a Solaris machine, the
      default directory on the page has an extra "/" when I install using "Typical"
      installation. For example and in my case, the following is displayed

      Installation Directory /export/sqe//glassfish3

      The correct path should be: /export/sqe/glassfish3

        Activity

        scatari added a comment -

        The installer generates this value based on $HOME environment variable. If the variable's value contains a
        "/" at the end, then one would get such generated paths. Closing as not a bug. Please feel free to reopen if
        $HOME does not have a "/" at the end.

        Alex Pineda added a comment -

        I just tried on 4 different platforms. All use the bash shell and all share the
        same .bashrc file. In none of the systems, the variable $HOME is set in the
        local directory. On MacOS, RHEL 5, OEL5 when I do echo $HOME, I get
        /export/sqe, but on Solaris, I get /export/sqe/, which based on your explanation
        it's why I see the extra "/" in my Solaris system. So, any possibility you
        could add some conditional logic to add or not to add a "/" to the default path?
        I know we're running out of time.

        scatari added a comment -

        Even with the two "/" s, it should create the directory with the correct path i,e $HOME/glassfish3 and not
        $HOME//glassfish3. Please let me know if this is not happening, then this is a serious issue.

        Alex Pineda added a comment -

        No. Is not creating a directory with the two "/"'s. Is just a display issue.

        scatari added a comment -

        Targeting this for 3.2, just a display issue.


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            Alex Pineda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: