glassfish
  1. glassfish
  2. GLASSFISH-14395

Webservices: empty wsdl file with https

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Trivial Trivial
    • Resolution: Unresolved
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: web_services_mgmt
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: ogs-3.1-b27-11_03_2010.zip

      Deploy a web services app, e.g. service.ear and go to app's General page. Click
      on View Endpoint for Stateless Session Bean. On new page click on the link for
      WSDL. New browser page will open with two urls. Click the https one (replacing
      localhost with machine name in url, if needed) and the page is empty (also
      source). The following is printed in server.log:

      [#|2010-11-03T14:43:52.255-0700|WARNING|oracle-glassfish3.1|javax.enterprise.webservices.org.glassfish.webservices|_ThreadID=15;_ThreadName=Thread-1;|Invalid
      request scheme for Endpoint HelloStatelessBean. Expected http . Received https|#]

        Activity

        Hide
        lidiam added a comment -

        Created an attachment (id=5319)
        screenshot

        Show
        lidiam added a comment - Created an attachment (id=5319) screenshot
        Hide
        Anissa Lam added a comment -

        This is not an admin gui issue.
        transfer to web services

        Show
        Anissa Lam added a comment - This is not an admin gui issue. transfer to web services
        Hide
        lidiam added a comment -

        Interestingly, when I view WSDL for Supplier Service, the file is displayed fine
        via http and https.

        Show
        lidiam added a comment - Interestingly, when I view WSDL for Supplier Service, the file is displayed fine via http and https.
        Hide
        jitu added a comment -

        Perhaps, https is not configured for this ejb app.
        Why does the admin gui show two urls(one with https, http) ?

        Show
        jitu added a comment - Perhaps, https is not configured for this ejb app. Why does the admin gui show two urls(one with https, http) ?
        Hide
        Bhakti Mehta added a comment -

        As Jitu mentioned pls confirm if https is setup for ejb ws because this is
        expected behaviour.

        Show
        Bhakti Mehta added a comment - As Jitu mentioned pls confirm if https is setup for ejb ws because this is expected behaviour.
        Hide
        Bhakti Mehta added a comment -

        As I mentioned in the comments this is expected behaviour if https is configured then you will be able to see the wsdl else you will get this error message.

        Show
        Bhakti Mehta added a comment - As I mentioned in the comments this is expected behaviour if https is configured then you will be able to see the wsdl else you will get this error message.

          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: