glassfish
  1. glassfish
  2. GLASSFISH-14414

Connection leak detection is enabled by default and gives incorect results with ACC

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b28
    • Component/s: jca
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      14,414

      Description

      If I create a connection pool using either asadmin or the admin console,
      connection leak tracing is enabled by default, with a leak timeout of 3 seconds.

      This means that any application client which keeps a connection open for more
      than three seconds will see a warning message after three seconds, despite this
      being perfectly normal and common for application clients. Example of warning
      message below:

      This is incorrect and confusing for users.

      Please do not enable connection leak tracing by default, or ensure it doesn't
      operate in the application client.

      example:
      [exec] WARNING: A potential connection leak detected for connection pool
      qcpool. The stack trace of the thread is
      > provided below :
      > [exec]
      com.sun.enterprise.resource.pool.ConnectionPool.setResourceStateToBusy(ConnectionPool.java:324)
      > [exec]
      com.sun.enterprise.resource.pool.ConnectionPool.getResourceFromPool(ConnectionPool.java:752)
      > [exec]
      com.sun.enterprise.resource.pool.ConnectionPool.getUnenlistedResource(ConnectionPool.java:630)
      > [exec]
      com.sun.enterprise.resource.pool.ConnectionPool.internalGetResource(ConnectionPool.java:523)
      > [exec]
      com.sun.enterprise.resource.pool.ConnectionPool.getResource(ConnectionPool.java:381)
      > [exec]
      com.sun.enterprise.resource.pool.PoolManagerImpl.getResourceFromPool(PoolManagerImpl.java:242)
      > [exec]
      com.sun.enterprise.resource.pool.PoolManagerImpl.getResource(PoolManagerImpl.java:167)
      > [exec]
      com.sun.enterprise.connectors.ConnectionManagerImpl.getResource(ConnectionManagerImpl.java:332)
      > [exec]
      com.sun.enterprise.connectors.ConnectionManagerImpl.internalGetConnection(ConnectionManagerImpl.java:295)
      > [exec]
      com.sun.enterprise.connectors.ConnectionManagerImpl.allocateConnection(ConnectionManagerImpl.java:227)
      > [exec]
      com.sun.enterprise.connectors.ConnectionManagerImpl.allocateConnection(ConnectionManagerImpl.java:156)
      > [exec]
      com.sun.enterprise.connectors.ConnectionManagerImpl.allocateConnection(ConnectionManagerImpl.java:151)
      > [exec]
      com.sun.genericra.outbound.ConnectionFactory.createConnection(ConnectionFactory.java:75)
      > [exec]
      com.sun.genericra.outbound.ConnectionFactory.createQueueConnection(ConnectionFactory.java:115)
      > [exec]
      test.performance.queue.client.PerformanceClient$Sender.getDataDestConnection(PerformanceClient.java:101)
      > [exec]
      test.performance.queue.client.PerformanceClient$Sender.getDataDestProducer(PerformanceClient.java:121)
      > [exec]
      test.performance.queue.client.PerformanceClient$Sender.sendMessagesToDestination(PerformanceClient.java:224)
      > [exec]
      >
      test.performance.queue.client.PerformanceClient$Sender.repeatedlySendMessagesToDestination(PerformanceClient.java:157)
      > [exec]
      test.performance.queue.client.PerformanceClient$Sender.runSender(PerformanceClient.java:85)
      > [exec]
      test.performance.queue.client.PerformanceClient.main(PerformanceClient.java:47)
      > [exec] sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      > [exec]
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      > [exec]
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      > [exec] java.lang.reflect.Method.invoke(Method.java:597)
      > [exec]
      org.glassfish.appclient.client.acc.AppClientContainer.launch(AppClientContainer.java:432)
      > [exec]
      org.glassfish.appclient.client.AppClientFacade.launch(AppClientFacade.java:154)
      > [exec]
      org.glassfish.appclient.client.AppClientGroupFacade.main(AppClientGroupFacade.java:65)

        Activity

        Nigel Deakin added a comment -

        This was observed with GlassFish 3.1 M6 (build 26).

        Satish Kumar added a comment -
            • Issue 14364 has been marked as a duplicate of this issue. ***
        Jagadish added a comment -

        FIX INFORMATION :
        https://glassfish-svn.dev.java.net/servlets/ReadMsg?list=commits&msgNo=25007
        svn log -v -r 42450

        Fix will be available in 5th Nov 2010 nightly / 3.1 promoted build 28


          People

          • Assignee:
            Jagadish
            Reporter:
            Nigel Deakin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: