Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: ogs-3.1-b28-11_05_2010.zip

      Deployed an osgi module and went to its general page. Tried to add a
      description but got the following error on save:

      An error has occurred
      org.jvnet.hk2.config.ValidationException: Validation Failed: is not of data
      type: java.lang.Boolean

      I see the following in server.log:

      [#|2010-11-05T16:31:07.253-0700|SEVERE|oracle-glassfish3.1|org.glassfish.admingui|_ThreadID=19;_ThreadName=Thread-1;|RestResponse.getResponse()
      failed. endpoint =
      'http://localhost:4848/management/domain/applications/application/org.apache.felix.eventadmin-1.2.2';
      attrs = '{libraries=null, availabilityEnabled=null, enabled=true,
      contextRoot=null,
      location=$

      {com.sun.aas.instanceRootURI}

      /applications/org.apache.felix.eventadmin-1.2.2/,
      description=no idea, name=org.apache.felix.eventadmin-1.2.2,
      asyncReplication=true, objectType=user, directoryDeployed=false}'; RestResponse:

      {"message":"org.jvnet.hk2.config.ValidationException: Validation Failed: is not of data type: java.lang.Boolean","exit_code":"FAILURE"}

      "|#]

        Activity

        lidiam added a comment -

        Created an attachment (id=5353)
        screenshot

        Anissa Lam added a comment -

        The issue is in the Availability checkbox. It is fixed. While fixing this, also made the following
        cleanup:

        • align checkbox better by adding dummy label
        • Availability Enable is shown only in cluster environment
        • edit of OSGI type deployment indicates the type
        • Remove "Enabled" word following the checkbox of Precompile JSP and Verifier
        • Add back ":" to labels thats missing ":"
        lidiam added a comment -

        Verified in promoted build b43.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: