Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1.2_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Build: b27
      OS: Mac OS X (10.5.8)
      Processor: 2.6 GHz Intel Core 2 Duo
      Memory 4 GB 667 MHz DDR2 SDRAM
      Browser: Firefox 3.6.12

      On this build, it took ~32 seconds for the console to come-up.

      Start time: 2010-11-05T17:56:44.525-0700
      End time: 2010-11-05T17:57:16.498-0700

      Significant time is spent with initializing the container, etc.

      GUI application took 16 seconds to initialize.

      Start time: 2010-11-05T17:57:00.458-0700
      End time: 2010-11-05T17:57:16.498-0700

      It would be useful if we can investigate what can be done to improve this.

      1. diffs
        6 kB
        sirajg
      2. server.log
        144 kB
        mzh777
      3. server.log
        17 kB
        Nazrul

        Issue Links

          Activity

          sirajg added a comment -

          Isn't console re-installed when upgrading to newer version? All these jars are inside the console's WEB-INF directory, so if the console is re-installed/re-deployed on upgrade, there shouldn't be any impact

          Anissa Lam added a comment -

          During the upgrade, the entire package (war) will be replaced. So, there is no issue of moving the WEB-INF/lib to another location. I have confirmed with Snjezana on this.

          Anissa Lam added a comment -

          Tested the changes on my Mac, Window XP on my virtual box and another window XP machine. Didn't see any issue.

          Here is the comparison with and without the changes on each of the machine i tested. This is using promoted build 15. The # is the msec it takes to load admingui, eg:

          [#|2012-01-03T15:12:25.549-0800|INFO|glassfish3.1.2|javax.enterprise.system.core
          .com.sun.enterprise.v3.server|_ThreadID=20;_ThreadName=Thread-38;|CORE10010: Loa
          ding application __admingui done in 14,895 ms|#]

          Here is the #, the first # is with the changes, 2nd is without.

          Window XP on my Virtual box:
          15021ms vs 38416ms

          Window XP (gateway)
          32093ms vs 52032ms

          My Mac:
          5909ms vs 8909ms

          All numbers are avg of 2 or 3 runs.

          sirajg added a comment -

          The improvements are because the web app classloader opens up jars in WEB-INF\lib directory. Moving these jars away avoids the unnecessary processing. Also, tld processing is avoided for these jars.

          I have kept only the console-core jar in the WEB-INF\lib directory. I am not sure if moving that away will cause any issues. If we have time to test. it might be a good idea to move that away also and try it out. It will improve performance further, a little bit.

          sirajg added a comment -

          Marking issue fixed, as the console initialization has improved. Two improvements were done :

          1) A Poststartup service was added, which initializes the console based on a few conditions, after server startup. This will improve perceived
          performance for frequent users of console and for cases where other instances have been created (DAS case)
          2) A general improvement to startup by reducing I/O when initializing console.


            People

            • Assignee:
              sirajg
              Reporter:
              Nazrul
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: