glassfish
  1. glassfish
  2. GLASSFISH-14465

[Perf] Lock contention while running specj 2010 benchmark

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.1
    • Fix Version/s: not determined
    • Component/s: jts
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      14,465
    • Tags:

      Description

      Ran specj 2010 benchmark on 5th Nov nightly & found there is performance
      regression. I got low numbers compare to b27 (available on 3th Nov). Thread dump
      indicated lots of thread are blocked in following state,

      java.lang.Thread.State: BLOCKED (on object monitor)
      at com.sun.jts.CosTransactions.LogFile.write(LogFile.java:157)

      • waiting to lock <0x00002aaac9b10830> (a
        com.sun.jts.CosTransactions.LogFile)
        at
        com.sun.jts.CosTransactions.CoordinatorLog.formatLogRecords(CoordinatorLog.java:1083)
      • locked <0x00002aabe83b7c90> (a com.sun.jts.CosTransactions.CoordinatorLog)
        at com.sun.jts.CosTransactions.CoordinatorLog.write(CoordinatorLog.java:536)
        at
        com.sun.jts.CosTransactions.TransactionState.setState(TransactionState.java:752)
        at
        com.sun.jts.CosTransactions.TopCoordinator.prepare(TopCoordinator.java:2014)
      • locked <0x00002aabeb5250f8> (a com.sun.jts.CosTransactions.TopCoordinator)
        at
        com.sun.jts.CosTransactions.CoordinatorTerm.commit(CoordinatorTerm.java:357)
        at
        com.sun.jts.CosTransactions.TerminatorImpl.commit(TerminatorImpl.java:250)
      • locked <0x00002aabeb525428> (a com.sun.jts.CosTransactions.TerminatorImpl)
        at com.sun.jts.CosTransactions.CurrentImpl.commit(CurrentImpl.java:623)
        at
        com.sun.jts.jta.TransactionManagerImpl.commit(TransactionManagerImpl.java:319)
        at
        com.sun.enterprise.transaction.jts.JavaEETransactionManagerJTSDelegate.commitDistributedTransaction(JavaEETransactionManagerJTSDelegate.java:172)
        at
        com.sun.enterprise.transaction.JavaEETransactionManagerSimplified.commit(JavaEETransactionManagerSimplified.java:871)
        at
        com.sun.ejb.containers.BaseContainer.completeNewTx(BaseContainer.java:5115)
        at
        com.sun.ejb.containers.BaseContainer.postInvokeTx(BaseContainer.java:4880)
        at
        com.sun.ejb.containers.MessageBeanContainer.afterMessageDeliveryInternal(MessageBeanContainer.java:1207)
        at
        com.sun.ejb.containers.MessageBeanContainer.afterMessageDelivery(MessageBeanContainer.java:1180)
        at
        com.sun.ejb.containers.MessageBeanListenerImpl.afterMessageDelivery(MessageBeanListenerImpl.java:86)
        at
        com.sun.enterprise.connectors.inbound.MessageEndpointInvocationHandler.invoke(MessageEndpointInvocationHandler.java:143)
        at $Proxy283.afterDelivery(Unknown Source)
        at com.sun.messaging.jms.ra.OnMessageRunner.run(OnMessageRunner.java:323)
      • locked <0x00002aaad8c49448> (a com.sun.messaging.jms.ra.DirectXAResource)
        at com.sun.enterprise.connectors.work.OneWork.doWork(OneWork.java:114)
        at
        com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.performWork(ThreadPoolImpl.java:496)
        at
        com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:537)

        Activity

        amitagarwal created issue -
        marina vatkina added a comment -

        This is an issue known for a very long time, and as such didn't change in the
        recent years

            • This issue has been marked as a duplicate of 6884 ***
        kenaiadmin made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 14465 46069
        deep_singh made changes -
        Tags PSRBUG
        deep_singh made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            marina vatkina
            Reporter:
            amitagarwal
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: