glassfish
  1. glassfish
  2. GLASSFISH-14506

WARNING: A HTTP GET method, public javax.ws.rs.core.Response after upgrade

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: not determined
    • Component/s: rest-interface
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      14,506

      Description

      Glassfish 3.1 nightly bundle tested (nov8)

      I see a lot of the following WARNINGs after and asupgrade and logging into
      the admin GUI and clicking on various admin GUI widgets:

      [#|2010-11-08T14:34:07.326-0500|WARNING|glassfish3.1|com.sun.jersey.spi.inject.Errors|_ThreadID=17;_ThreadName=Thread-2;|The
      following warnings have been detected with resource and/or provider classes:
      WARNING: A HTTP GET method, public javax.ws.rs.core.Response
      org.glassfish.admin.rest.resources.TemplateCommandGetResource.processGet(org.glassfish.api.admin.ParameterMap),
      should not consume any entity.|#]

      [#|2010-11-08T14:34:54.715-0500|WARNING|glassfish3.1|com.sun.jersey.spi.inject.Errors|_ThreadID=17;_ThreadName=Thread-2;|The
      following warnings have been detected with resource and/or provider classes:
      WARNING: A HTTP GET method, public javax.ws.rs.core.Response
      org.glassfish.admin.rest.resources.TemplateCommandGetResource.processGet(org.glassfish.api.admin.ParameterMap),
      should not consume any entity.|#]

      [#|2010-11-08T14:34:54.776-0500|WARNING|glassfish3.1|com.sun.jersey.spi.inject.Errors|_ThreadID=17;_ThreadName=Thread-2;|The
      following warnings have been detected with resource and/or provider classes:
      WARNING: A HTTP GET method, public javax.ws.rs.core.Response
      org.glassfish.admin.rest.resources.TemplateCommandGetResource.processGet(org.glassfish.api.admin.ParameterMap),
      should not consume any entity.|#]

        Activity

        Hide
        adf59 added a comment -

        Add 3.1-upgrade keywords.

        Also this was with a developer profile installation of V2.1.1.

        Show
        adf59 added a comment - Add 3.1-upgrade keywords. Also this was with a developer profile installation of V2.1.1.
        Hide
        Anissa Lam added a comment -

        I don't think this is related to upgrade.
        I start seeing this WARNING over the weekend.
        I have this in my server.log, when i just start the server with latest code.

        [#|2010-11-08T10:35:18.015-
        0800|WARNING|glassfish3.1|com.sun.jersey.spi.inject.Errors|_ThreadID=254;_ThreadName=admin-
        thread-pool-4848(5);|The following warnings have been detected with resource and/or provider
        classes:
        WARNING: A HTTP GET method, public javax.ws.rs.core.Response
        org.glassfish.admin.rest.resources.TemplateCommandGetResource.processGet(org.glassfish.api.adm
        in.ParameterMap), should not consume any entity.|#]

        Let me see if Ludo has what this is about, I think he is working in this area.

        Show
        Anissa Lam added a comment - I don't think this is related to upgrade. I start seeing this WARNING over the weekend. I have this in my server.log, when i just start the server with latest code. [#|2010-11-08T10:35:18.015- 0800|WARNING|glassfish3.1|com.sun.jersey.spi.inject.Errors|_ThreadID=254;_ThreadName=admin- thread-pool-4848(5);|The following warnings have been detected with resource and/or provider classes: WARNING: A HTTP GET method, public javax.ws.rs.core.Response org.glassfish.admin.rest.resources.TemplateCommandGetResource.processGet(org.glassfish.api.adm in.ParameterMap), should not consume any entity.|#] Let me see if Ludo has what this is about, I think he is working in this area.
        Hide
        ludo added a comment -

        not upgrade related.

        looking at it. No real side effect except this ugly warning.

        Show
        ludo added a comment - not upgrade related. looking at it. No real side effect except this ugly warning.
        Hide
        ludo added a comment -

        .

        Show
        ludo added a comment - .
        Hide
        ludo added a comment -

        Fixed...
        Revision: 42577

        I would still want to be able to do things like:
        curl -i -X GET -H "Content-Type: application/json" -d '

        {"milliseconds":false}

        '
        http://localhost:4848/management/domain/uptime

        But not sure yet how, with this warning. Maybe such thing is not spec compliant, and for GET, all params
        should be url encoded and not passed as json or xml?

        Show
        ludo added a comment - Fixed... Revision: 42577 I would still want to be able to do things like: curl -i -X GET -H "Content-Type: application/json" -d ' {"milliseconds":false} ' http://localhost:4848/management/domain/uptime But not sure yet how, with this warning. Maybe such thing is not spec compliant, and for GET, all params should be url encoded and not passed as json or xml?

          People

          • Assignee:
            ludo
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: