glassfish
  1. glassfish
  2. GLASSFISH-14507

SEVERE RuntimeException could not be mapped to a response

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: not determined
    • Component/s: rest-interface
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      14,507

      Description

      Testing Admin GUI features after upgrade of V2.1.1 developer domain to V3.1.
      Used latest-glassfish.zip dated nov8.

      The following server.log SEVERE error occurs on a system upgrade from V2.1.1
      to V3.1 developer profile. If you click on

      Configurations->server-config->JVM settings->Profiler

      [#|2010-11-08T14:54:26.807-0500|SEVERE|glassfish3.1|com.sun.jersey.spi.container.ContainerResponse|_ThreadID=17;_ThreadName=Thread-2;|The
      RuntimeException could not be mapped to a response, re-throwing to the HTTP
      container
      java.lang.NullPointerException
      at
      org.glassfish.admin.rest.resources.CollectionLeafResource.setParentAndTagName(CollectionLeafResource.java:119)
      at
      org.glassfish.admin.rest.resources.generatedASM.ProfilerResource.getJvmOptionsResource(Unknown
      Source)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.invokeSubLocator(SubLocatorRule.java:157)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:97)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:121)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:121)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:121)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:121)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:121)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:86)
      at
      com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:136)
      at
      com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:74)
      at
      com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1357)
      at
      com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1289)
      at
      com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1239)
      at
      com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1229)
      at
      com.sun.jersey.server.impl.container.grizzly.GrizzlyContainer._service(GrizzlyContainer.java:180)
      at
      com.sun.jersey.server.impl.container.grizzly.GrizzlyContainer.service(GrizzlyContainer.java:145)
      at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:180)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:817)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at
      com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)

      #]

        Activity

        adf59 added a comment -

        Add 3.1-upgrade to keywords

        Anissa Lam added a comment -

        Can you attach domain.xml before and after the upgrade ?
        Did you create a profile before doing the upgrade ?

        Since the NPE is from REST, assign to REST team for initial evaluation.

        Anissa Lam added a comment -

        I also want to mention this is not related to upgrade.
        I saw the following in my server.log, when i just start server with latest code.

        To reproduce: In GUI:
        Go to: Configuration -> server-config -> JVM Settings.

        • create a profile
        • profile created without issue
        • delete the profile

        See the following exception.

        [#|2010-11-08T12:05:43.770-
        0800|SEVERE|glassfish3.1|com.sun.jersey.spi.container.ContainerResponse|_ThreadID=548;_Thread
        Name=admin-thread-pool-4848(13);|The RuntimeException could not be mapped to a response,
        re-throwing to the HTTP container
        java.lang.NullPointerException
        at
        org.glassfish.admin.rest.resources.CollectionLeafResource.setParentAndTagName(CollectionLeafReso
        urce.java:119)
        at
        org.glassfish.admin.rest.resources.generatedASM.ProfilerResource.getJvmOptionsResource(Unknown
        Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        Also want to mention that even though the exception is thrown, It seems to be doing what we
        want.

        Since this is not related to upgrade, should i remove the 3.1-upgrade keyword ??

        ludo added a comment -

        not upgrade related.
        Looking at it.

        ludo added a comment -

        I prevent the NPE now to be shown.
        No real impact.

        ludo added a comment -

        But for profiler added, I see this in the log:

        [#|2010-11-08T12:46:08.494-0800|WARNING|glassfish3.1|null|_ThreadID=20;_ThreadName=Thread-
        1;|Unprocessed event : UnprocessedChangeEvent

        {PropertyName=enabled, OldValue = true, NewValue = false, Source = GlassFishConfigBean.com.sun.enterprise.config.serverbeans.Profiler}

        , reason = Creation
        or changes to a profiler require restart, when = 1289249168494|#]

        Do we handle that restart flag in the GUI?


          People

          • Assignee:
            ludo
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: