glassfish
  1. glassfish
  2. GLASSFISH-14530

Unable to stop standalone instance and cluster instance

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b28
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: HP-UX
      Platform: HP

    • Issuezilla Id:
      14,530

      Description

      Unable to stop standalone instance and cluster instance , asadmin command fails
      with timed out error message.

      Steps to reproduce :

      1.Install 3.1B27 on hpux machine.
      Note : Custom installation -> create cluster / create standalone instance.
      2.From command line ,execute asadmin start-instance / start-cluster , instance
      will start up without any issues.
      3.Try to stop the standalone / cluster instance . asadmin stop-instance command
      fails with timed error message.

      Console Output :
      ----------------

      bash-2.00# ./asadmin version -v
      Version = Oracle GlassFish Server 3.1 (build 27), JRE version 1.6.0.07
      Command version executed successfully.

      bash-2.00# ./asadmin list-instances --user admin
      instance1 not running
      Command list-instances executed successfully.

      bash-2.00# ./asadmin start-instance --user admin instance1
      Waiting for instance1 to start .................
      Successfully started the instance: instance1
      instance Location: /space/glassfish/3.1/b27/glassfish/nodes/localhost/instance1
      Log File:
      /space/glassfish/3.1/b27/glassfish/nodes/localhost/instance1/logs/server.log
      Admin Port: 24848
      Command start-local-instance executed successfully.
      The instance, instance1, was started on host localhost
      Command start-instance executed successfully.

      bash-2.00# ./asadmin list-instances --user admin
      instance1 running
      Command list-instances executed successfully.

      bash-2.00# ./asadmin stop-instance --user admin instance1
      org.glassfish.api.admin.CommandException: remote failure: Timed out waiting for
      instance1 to stop.
      Command stop-instance failed.
      bash-2.00# ./asadmin stop-instance
      Enter the value for the instanceName operand> instance1
      org.glassfish.api.admin.CommandException: remote failure: Timed out waiting for
      instance1 to stop.
      Command stop-instance failed.

      ---------------cluster start-up--------------------

      bash-2.00# ./asadmin version -v
      Version = Oracle GlassFish Server 3.1 (build 27), JRE version 1.6.0.07
      Command version executed successfully.

      bash-2.00# ./asadmin list-instances
      instance1 not running
      Command list-instances executed successfully.

      bash-2.00# ./asadmin start-cluster --user admin c1
      Command start-cluster executed successfully.

      bash-2.00# ./asadmin list-instances
      instance1 running
      Command list-instances executed successfully.

      bash-2.00# ./asadmin stop-cluster --user admin c1
      org.glassfish.api.admin.CommandException: remote failure: instance1: Timed out
      waiting for instance1 to stop.
      The command stop-instance failed for: instance1
      Command stop-cluster failed.

        Activity

        Tom Mueller added a comment -

        Are you seeing this only on HP-UX?

        Can you provide access to the HP-UX machine to debug?

        Recently there were some problems with stop-local-instance which have now been
        fixed. However, the symptoms from that problem were different than what you are
        seeing. Can you please retry this test with a build from Nov 9 or later?

        hsbhavya added a comment -

        Machine Details :
        Host : jeshp175.india.sun.com ( root / abc123 )
        Glassfish Install location : /opt/glassfish3 OR /space/glassfish/3.1/b27

        I have tried the scenario only on HPUX machine , I am not sure about other OS.

        Tom Mueller added a comment -

        This is fixed on the trunk, should be in b28. An install of GlassFish from today
        is now available on that system in the /space/glassfish/3.1/14530-test directory
        and a stand-alone instance and a cluster can be started and stopped successfully.

        I suspect that this is actually a duplicate of the problems we were seeing with
        secure admin.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            hsbhavya
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: