glassfish
  1. glassfish
  2. GLASSFISH-14585

EJBContainer#createEJBContainer() fails if spaces in module path

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.1
    • Fix Version/s: not determined
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      I have a Hudson build that was failing all my EJB tests, whereas they all ran
      fine on my machine.

      Racked my brain, and then renamed the job so that the job name--and hence one of
      the directories in the path--no longer had spaces in it.

      After this point, EJB tests ran fine. Looks like EJBContainerImpl can't deal
      with paths to the modules that it deploys with spaces in them.

        Activity

        Bhavanishankar added a comment -

        Transferring to Marina.

        marina vatkina added a comment -

        I can't reproduce it. I'll attach a test case that I used

        marina vatkina added a comment -

        Created an attachment (id=5473)
        the test


          People

          • Assignee:
            marina vatkina
            Reporter:
            ljnelson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: