glassfish
  1. glassfish
  2. GLASSFISH-14642

(Regression) GlassFish Embedded All 3.1-b28 bundles JUnit

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: packaging
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      14,642

      Description

      A bug in the dependency tree somewhere cause the GlassFish Embedded All artifact
      to bundle JUnit. It causes some interesting version conflicts with the users
      selected version test framework...

      http://download.java.net/maven/glassfish/org/glassfish/extras/glassfish-embedded-
      all/3.1-b28/

        Activity

        Alexis MP added a comment -

        cc

        Bhavanishankar added a comment -

        Regular GlassFish also bundles JUnit (gf_install_dir/modules/junit.jar). I
        quickly checked to see that is is coming from v3/packager/glassfish-hk2.

        If JUnit should not be bundled with GlassFish, it looks like a GlassFish
        packaging issue, not an embedded issues. Embedded (glassfish-embedded-all.jar)
        bundles subset of what regular GlassFish bundles.

        Hence transferring.

        Snjezana Sevo-Zenzerovic added a comment -

        No, junit.jar is not intended to be bundled with GlassFish. It is being pulled
        in as transitive dependency of osgi-resource-locator module which is binary
        dependency produced by HK2 project. I'll check its POM and exclude it explicitly
        during glassfish-hk2 build until the original POM is fixed in HK2 project.

        Snjezana Sevo-Zenzerovic added a comment -

        FWIW, this is regression introduced in b28. class-model.jar is being pulled into
        distribution starting with HK2 1.0.61 and it has junit.jar defined as compile
        dependency...

        Snjezana Sevo-Zenzerovic added a comment -

        I am marking this as fixed since dependency exclusion has been added to
        GlassFish packager module and junit.jar is removed from the distribution. Once
        the fix is applied to HK2 pom file, this workaround can be removed.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Aslak Knutsen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: