glassfish
  1. glassfish
  2. GLASSFISH-14708

Clicking on an instance in cluster changes the state from "Running" -> "Required Restart"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      14,708

      Description

      With a fresh b29

      • Create a cluster "myCluster" with 2 instances "in1" and "in2" on localhost
      • Start the cluster and both the instances are shown in "Running" state.
      • Go to Instances tab, click on "in1" and the following error is thrown on the server log

      [#|2010-11-15T18:26:50.497-
      0800|WARNING|glassfish3.1|javax.enterprise.system.container.web.com.sun.enterprise.web|_ThreadID=
      240;_ThreadName=admin-thread-pool-4848(6);|StandardWrapperValve[FacesServlet]: PWC1406:
      Servlet.service() for servlet FacesServlet threw exception
      java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while attempting to process a
      'afterCreate' event for 'event247'.
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      422)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      394)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.afterCreate(LayoutComponent.java:363)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.getChild(LayoutComponent.java:294)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:556)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:590)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:590)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:551)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:507)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:507)
      at com.sun.jsftemplating.layout.LayoutViewHandler.createView(LayoutViewHandler.java:255)
      at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:244)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      at com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:113)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:395)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1534)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:343)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:233)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:256)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:279)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.doChainInvoke(StandardPipeline.java:600)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:96)
      at
      com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.jav
      a:91)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:326)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:227)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:228)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:817)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedMethodAccessor261.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handler.java:442)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      420)
      ... 45 more
      Caused by: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while attempting to
      process a 'beforeCreate' event for 'web-networkPorts'.
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      422)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      394)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.beforeCreate(LayoutComponent.java:348)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.getChild(LayoutComponent.java:288)
      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:556)
      at
      org.glassfish.admingui.common.handlers.PluginHandlers.includeIntegrationPoint(PluginHandlers.java:44
      6)
      at
      org.glassfish.admingui.common.handlers.PluginHandlers.includeIntegrationPoints(PluginHandlers.java:3
      89)
      at
      org.glassfish.admingui.common.handlers.PluginHandlers.includeIntegrations(PluginHandlers.java:192)
      ... 50 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handler.java:442)
      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:
      420)
      ... 57 more
      Caused by: java.lang.RuntimeException: An error occurred during replication
      at org.glassfish.admingui.common.util.RestUtil.parseResponse(RestUtil.java:305)
      at org.glassfish.admingui.common.util.RestUtil.restRequest(RestUtil.java:174)
      at org.glassfish.admingui.common.util.RestUtil.restRequest(RestUtil.java:131)
      at org.glassfish.admingui.common.util.RestUtil.resolveToken(RestUtil.java:126)
      at org.glassfish.admingui.common.handlers.UtilHandlers.resolveTokens(UtilHandlers.java:640)
      ... 63 more
      Caused by: java.lang.RuntimeException: An error occurred during replication
      at org.glassfish.admingui.common.util.RestUtil.parseResponse(RestUtil.java:278)
      ... 67 more

      #]

      Admin Console shows the output as in attached "Picture1".

      Selecting myCluster shows "in1" to be in "Required Restart" state. This is shown in attached "Picture2".

      Click on "in2" and it goes back to "Required Restart" state.

      Selecting the two instances and clicking on "Start" shows the following log message in console:

      [#|2010-11-15T18:40:05.120-
      0800|INFO|glassfish3.1|javax.enterprise.system.tools.admin.com.sun.enterprise.v3.admin.cluster|_Thre
      adID=240;_ThreadName=admin-thread-pool-4848(6);|Instance in1 is already running.|#]

      [#|2010-11-15T18:40:05.147-
      0800|INFO|glassfish3.1|javax.enterprise.system.tools.admin.com.sun.enterprise.v3.admin.cluster|_Thre
      adID=115;_ThreadName=admin-thread-pool-4848(4);|Instance in2 is already running.|#]

      But admin console shows the state as "Restart Required".

      The application can be deployed to the cluster though.

        Activity

        Anissa Lam added a comment -

        The 1st issue is fixed, the 2nd issue reported here cannot reproduce, not sure if it is related to the
        1st issue.
        I am marking this resolved. If you still see similar problem, please reopen.

        Anissa Lam added a comment -

        So, there are 2 issues here.
        1. trying to get to a running instance general page results in exception:
        aused by: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while attempting
        to
        process a 'beforeCreate' event for 'web-networkPorts'.
        This is issue# 14425. This is fixed after b29.

        2. the instance status becomes "restart required", and click on 'start' says it is already running.
        Have you tried doing CLI "%asadmin list-instances --long" to see what CLI says ?
        This is a 'Start' button, not 'Re-start', so, doing a 'start' on a running instance is a no-op and tell
        you the instance is already running. I think this is doing the right thing.
        I guess the issue here is: Does GUI tell you the correct status, Are these instances really in restart-
        required state? So, please verify with CLI, and if the state is correct, I don't think there is any GUI
        issue here.

        Downgrading to P3 since we have fixed #14425 and you can go to the instance page.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            arungupta
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: