glassfish
  1. glassfish
  2. GLASSFISH-14778

when using "asadmin get --monitor=true server*errorcount*"

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: not determined
    • Component/s: monitoring
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      14,778

      Description

      [Regression] when using "asadmin get --monitor=true server*errorcount*" fail in
      build 30 but it pass build 27 passed.

      The pattern "server*errorcount*" is not work on promoted build 30.

      The pattern "jsp" works now, but not "server*errorcount*".

      /glassfish3/glassfish/bin/asadmin get --monitor=true server*errorcount*
      Command get failed.
      org.glassfish.api.admin.CommandException: remote failure: The specified target,
      server*errorcount*, is not a valid server's name.

        Activity

        Byron Nevins added a comment -

        What does it do on 2.1?
        What does it do on 3.0?
        What is it SUPPOSED to do on 3.1?

        These 3 questions need to be answered for EVERY bug like this.

        Byron Nevins added a comment -

        Results on 2.1

        C:\glassfish\bin>asadmin get -m server*errorcount*
        No value name specified = server*errorcount*
        CLI137 Command get failed.

        ===========================================

        Results on 3.0.1

        C:\glassfishv3\glassfish\bin>asadmin get -m server*errorcount*

        Command get executed successfully.
        =============================================

        Working on it. Thanks for finding it. Low Hanging Fruit.

        Byron Nevins added a comment -

        Definitely not a regression. Neither 2.1 nor 3.0 handled it at all.
        3.1 will handle it correctly soon...

        Homer Yau added a comment -

        Thanks for looking in to this issue.

        The "regression" is because it fail on current promoted build 30; versus , it
        pass on previous 3.1 promoted build 27.

        Byron Nevins added a comment -

        Here are the results after the fix:

        C:\gf\v3>asadmin get -m server*foo*
        Command get executed successfully.

        C:\gf\v3\core\kernel>svn commit
        Sending kernel\src\main\java\com\sun\enterprise\v3\admin\GetCommand.java
        Sending
        kernel\src\main\java\com\sun\enterprise\v3\admin\MonitoringReporter.java
        Transmitting file data ..
        Committed revision 42935.


          People

          • Assignee:
            Byron Nevins
            Reporter:
            Homer Yau
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: