Issue Details (XML | Word | Printable)

Key: GLASSFISH-14824
Type: Bug Bug
Status: Closed Closed
Resolution: Duplicate
Priority: Blocker Blocker
Assignee: Satish Kumar
Reporter: zorro
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

[BLOCKING]: b30 is not functioning

Created: 19/Nov/10 03:51 PM   Updated: 29/Nov/10 04:44 AM   Resolved: 29/Nov/10 04:44 AM
Component/s: jms
Affects Version/s: 3.1
Fix Version/s: not determined

Time Tracking:
Not Specified

Environment:

Issuezilla Id: 14,824
Tags:
Participants: kumara, Satish Kumar and zorro


 Description  « Hide

Oracle GlassFish Server 3.1 (build 30)

This is a test stopper.

Installed das, and three nodes on separate machines.
GLASSFISH-1: admin GUI is not loading and is frozen with an empty screen.
GLASSFISH-2: Cluster nodes are not accessible.
das log shows:

[#|2010-11-19T15:13:10.201-0800|WARNING|oracle-glassfish3.1|java.util.prefs|_ThreadID=15;_ThreadName=Thread-1;|Couldn't
flush user prefs: java.util.prefs.BackingStoreException: Couldn't get file lock.|#]

All logs:
http://aras2.us.oracle.com:8080/logs/gf31/gms/stress_b30_nov19/scenario_0001_Fri_Nov_19_15_42_39_PST_2010/



zorro added a comment - 19/Nov/10 04:56 PM

Installed b30 3 times and the product did not work.
The node's logs on machine the second and third machine show:
java.lang.Exception
at
com.sun.enterprise.connectors.inbound.ConnectorMessageBeanClient.setup(ConnectorMessageBeanClient.java:233)
....
javax.resource.NotSupportedException: MQRA:EC:Error creating Remote Message
Consumer:
...


kumara added a comment - 19/Nov/10 06:12 PM

Likely a configuration issue. -> jms because the exception is during auto-creation of topics.

The admin console issue is being addressed separately. The update check is going to be removed from
initialization of admin console to avoid situations like this. (The machine was moved to a different
network and now requires a HTTP proxy to connect to Internet and therefore the timeout message in
DAS log file).

Caused by: com.sun.messaging.jms.JMSException: [CREATE_DESTINATION_REPLY(35)] [C4036]: A broker
error occurred. :[503] [B4286]: [Thread-jms[0]]Auto-creation of destination richAppTopic is not allowed
because service jms is currently in restricted service mode: Persistent store has not been synchronized
with master broker [broker2(mq://10.133.184.122:27676/)] user=guest,
broker=localhost:27676(41939)
at
com.sun.messaging.jmq.jmsclient.ProtocolHandler.throwServerErrorException(ProtocolHandler.java:407
9)
at com.sun.messaging.jmq.jmsclient.ProtocolHandler.createDestination(ProtocolHandler.java:1462)
at com.sun.messaging.jmq.jmsclient.ProtocolHandler.createDestination(ProtocolHandler.java:1396)
at com.sun.messaging.jmq.jmsclient.ProtocolHandler.addInterest(ProtocolHandler.java:2234)
at com.sun.messaging.jmq.jmsclient.ProtocolHandler.addInterest(ProtocolHandler.java:2223)
at com.sun.messaging.jmq.jmsclient.WriteChannel.addInterest(WriteChannel.java:101)
at com.sun.messaging.jmq.jmsclient.ConnectionImpl.addInterest(ConnectionImpl.java:1378)
at com.sun.messaging.jmq.jmsclient.Consumer.registerInterest(Consumer.java:153)
at
com.sun.messaging.jmq.jmsclient.MessageConsumerImpl.addInterest(MessageConsumerImpl.java:184)
at com.sun.messaging.jmq.jmsclient.MessageConsumerImpl.init(MessageConsumerImpl.java:165)
at com.sun.messaging.jmq.jmsclient.MessageConsumerImpl.<init>
(MessageConsumerImpl.java:123)
at com.sun.messaging.jmq.jmsclient.TopicSubscriberImpl.<init>(TopicSubscriberImpl.java:110)
at
com.sun.messaging.jmq.jmsclient.UnifiedSessionImpl.createSubscriber(UnifiedSessionImpl.java:319)
at
com.sun.messaging.jmq.jmsclient.UnifiedSessionImpl.createConsumer(UnifiedSessionImpl.java:637)
at
com.sun.messaging.jmq.jmsclient.UnifiedSessionImpl.createConsumer(UnifiedSessionImpl.java:583)
at
com.sun.messaging.jms.ra.EndpointConsumer.createRemoteMessageConsumer(EndpointConsumer.java:
548)
... 39 more


Satish Kumar added a comment - 29/Nov/10 04:44 AM

Duplicate of 14788