glassfish
  1. glassfish
  2. GLASSFISH-14862

class java.lang.RuntimeException after changing log levels in a new configuration.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: rest-interface
    • Labels:
      None
    • Environment:

      OS: Solaris Sparc 10
      Browser: firefox 3.6

      Description

      build used: GF V3.1 nightly dated 11/29

      Create a new configuration (instance1-config) by copying from default-config.
      Create a standalone instance referring the new configuration (instance1-config), and start the instance.
      Under the instance1-config/Logger Settings/Log Levels, select all modules, and select the level to either INFO, or OFF, and SEVERE, and click SAVE button.
      We see "class java.lang.RuntimeException".

      domain server.log has the following:
      [#|2010-11-29T14:22:27.449-0800|SEVERE|glassfish3.1|javax.enterprise.system.std.
      com.sun.enterprise.server.logging|_ThreadID=15;_ThreadName=Thread-1;|javax.faces
      .FacesException: java.lang.reflect.InvocationTargetException while attempting to
      process a 'command' event for 'saveButton'.
      at com.sun.faces.lifecycle.InvokeApplicationPhase.execute(InvokeApplicat
      ionPhase.java:89)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:395)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java
      :1534)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:343)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:215)
      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:233)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:256)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:215)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
      alve.java:279)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
      alve.java:175)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.j
      ava:655)
      at org.apache.catalina.core.StandardPipeline.doChainInvoke(StandardPipel
      ine.java:600)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:96)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESess
      ionLockingStandardPipeline.java:91)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
      ava:162)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.j
      ava:326)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
      a:227)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(Container
      Mapper.java:228)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:8
      17)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFil
      ter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultPro
      tocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.jav
      a:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java
      :79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextT
      ask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.
      java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadP
      ool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool
      .java:513)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: java.lang.reflect.InvocationTargetExcepti
      on while attempting to process a 'command' event for 'saveButton'.
      at com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHa
      ndlers(LayoutElementBase.java:422)
      at com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHa
      ndlers(LayoutElementBase.java:394)
      at com.sun.jsftemplating.layout.event.CommandActionListener.invokeComman
      dHandlers(CommandActionListener.java:150)
      at com.sun.jsftemplating.layout.event.CommandActionListener.processActio
      n(CommandActionListener.java:98)
      at javax.faces.event.ActionEvent.processListener(ActionEvent.java:88)
      at javax.faces.component.UIComponentBase.broadcast(UIComponentBase.java:
      769)
      at javax.faces.component.UICommand.broadcast(UICommand.java:300)
      at com.sun.webui.jsf.component.WebuiCommand.broadcast(WebuiCommand.java:
      166)
      at javax.faces.component.UIViewRoot.broadcastEvents(UIViewRoot.java:794)
      at javax.faces.component.UIViewRoot.processApplication(UIViewRoot.java:1
      259)
      at com.sun.faces.lifecycle.InvokeApplicationPhase.execute(InvokeApplicat
      ionPhase.java:81)
      ... 33 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handl
      er.java:442)
      at com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHa
      ndlers(LayoutElementBase.java:420)
      ... 43 more
      Caused by: java.lang.RuntimeException: An error occurred during replication
      at org.glassfish.admingui.common.util.RestUtil.parseResponse(RestUtil.ja
      va:310)
      at org.glassfish.admingui.common.util.RestUtil.restRequest(RestUtil.java
      :179)
      at org.glassfish.admingui.common.util.RestUtil.restRequest(RestUtil.java
      :134)
      at org.glassfish.admingui.common.handlers.LoggingHandlers.updateLoggerLe
      vels(LoggingHandlers.java:136)
      ... 49 more
      Caused by: java.lang.RuntimeException: An error occurred during replication
      at org.glassfish.admingui.common.util.RestUtil.parseResponse(RestUtil.ja
      va:283)
      ... 52 more

        Issue Links

          Activity

          sirajg added a comment -

          The underlying cause : An error occurred during replication
          indicates this was probably a failure in the REST layer. Reassigning issue, possible cause could be missing/incorrect annotation.

          Jason Lee added a comment -

          There appears to be a bug in the CLI for which an issue has been filed.

          Anissa Lam added a comment -

          Seeking help from Ludo as Jason has many on his plate.

          ludo added a comment -

          no time for me this week on that...@Javaone conf...
          Jason mentions a CLI bug. Which one?

          ludo added a comment -

          agree with Jason: seems like 14862 CLI bug

          Jason Lee added a comment -

          The CLI fix addressed this issue.

          shaline added a comment -

          Verified in promoted b39.


            People

            • Assignee:
              Jason Lee
              Reporter:
              shaline
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: