Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.1_dev
    • Fix Version/s: 3.1_dev
    • Component/s: failover
    • Labels:
      None
    • Environment:

      All

      Description

      I am using Build 30

      It happens for Modified Attribute test

      [#|2010-11-24T03:36:12.028+0000|INFO|oracle-glassfish3.1|null|_ThreadID=16;_ThreadName=Thread-1;|Started bundle: file:/export/ha/glassfish3/glassfish/modules/autostart/osgi-jta.jar|#]

      [#|2010-11-24T03:36:12.116+0000|FINE|oracle-glassfish3.1|org.shoal.ha.cache.interceptor.transmit|_ThreadID=16;_ThreadName=Thread-1;ClassName=org.shoal.ha.cache.impl.interceptor.TransmitInterceptor;MethodName=onTransmit;|/BMPEBRefFO: TransmitInterceptor./BMPEBRefFO:onTransmit() Sent ReplicationFramePayloadCommand: contains 1 commands to instance104; size: 773|#]

      [#|2010-11-24T03:36:14.835+0000|WARNING|oracle-glassfish3.1|org.shoal.ha.cache.command.load_request|_ThreadID=16;_ThreadName=Thread-1;|LoadRequestCommand timed out while waiting for resultjava.util.concurrent.TimeoutException|#]

      [#|2010-11-24T03:36:14.835+0000|FINE|oracle-glassfish3.1|org.shoal.ha.cache.command.load_request|_ThreadID=16;_ThreadName=Thread-1;ClassName=org.shoal.adapter.store.commands.StoreableLoadRequestCommand;MethodName=getResult;|LoadRequestCommand timed out while waiting for result
      java.util.concurrent.TimeoutException
      at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:228)
      at java.util.concurrent.FutureTask.get(FutureTask.java:91)
      at org.shoal.adapter.store.commands.StoreableLoadRequestCommand.getResult(StoreableLoadRequestCommand.java:184)
      at org.shoal.adapter.store.StoreableReplicatedBackingStore.doLoad(StoreableReplicatedBackingStore.java:264)
      at org.shoal.adapter.store.StoreableReplicatedBackingStore.load(StoreableReplicatedBackingStore.java:212)
      at org.shoal.adapter.store.StoreableReplicatedBackingStore.load(StoreableReplicatedBackingStore.java:62)
      at org.glassfish.web.ha.session.management.ReplicationAttributeStore.load(ReplicationAttributeStore.java:244)
      at org.glassfish.web.ha.session.management.ReplicationAttributeStore.load(ReplicationAttributeStore.java:238)
      at org.apache.catalina.session.PersistentManagerBase.doSwapIn(PersistentManagerBase.java:1055)
      at org.apache.catalina.session.PersistentManagerBase.swapIn(PersistentManagerBase.java:1016)
      at org.apache.catalina.session.PersistentManagerBase.swapIn(PersistentManagerBase.java:982)
      at org.apache.catalina.session.PersistentManagerBase.findSession(PersistentManagerBase.java:738)
      at org.apache.catalina.session.ManagerBase.findSession(ManagerBase.java:874)
      at org.apache.catalina.connector.Request.doGetSession(Request.java:2833)
      at org.apache.catalina.connector.Request.getSession(Request.java:2560)
      at org.apache.catalina.connector.RequestFacade.getSession(RequestFacade.java:920)
      at org.apache.catalina.core.StandardHostValve.preInvoke(StandardHostValve.java:623)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:154)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:323)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:227)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:170)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:817)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:662)

        Activity

        Mahesh Kannan added a comment -

        14865 merely reports that the loadRequest timed out after failing to load the data within 3 sec. The root cause of this issue is actually 14827 which I am marking it as a Blocker


          People

          • Assignee:
            Mahesh Kannan
            Reporter:
            gopaljorapur
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: