glassfish
  1. glassfish
  2. GLASSFISH-15

create-domain does not document properly a way to set the jmx admin port

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.0pe
    • Component/s: command_line_interface
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Linux

    • Issuezilla Id:
      15

      Description

      asadmin create-domain does not seem to have any way to set the JMX_ADMIN port.

      All the ways I've tried either endup in errors or with it printing:
      Using default port 8,686 for JMX_ADMIN.

      asadmin help create-domain talks about a --admin.jmxport option, but using that option always
      results in the error:
      CLI019 Invalid number of operands. Number of operands should be equal to 1.

      There does not seem to be a value that you can set for --domainproperties, and if there is one, it's not
      documented in "asadmin help create-domain"

      Here's a note about this from Kedar Mhaswade to Jane Young about it:
      ------
      There is no option like --admin.jmxport. The correct option way is: --domainproperties
      admin.jmxPort=<port>.
      The create-domain help is broken as you correctly identified. But there is already a bug that I filed on
      this: 6207363, which we will fix for 9.0.
      I think we fixed this for 8.1 UR1/UR2, but apparently it is not ported to 9.0 codebase.
      ------

      Thanks,
      Dan.

        Activity

        Hide
        danbrice added a comment -

        I Tested:

        create-domain --domainproperties domain.jmxPort=xxxx

        It works for me also.

        Now the documentation just needs to be updated for "asadmin help create-domain".

        Thanks,
        Dan.

        Show
        danbrice added a comment - I Tested: create-domain --domainproperties domain.jmxPort=xxxx It works for me also. Now the documentation just needs to be updated for "asadmin help create-domain". Thanks, Dan.
        Hide
        hl34125 added a comment -

        Chinmayee,

        Vipin reassigned the create-domain command to you. I believe this fix is already
        done in the mpage, but please verify and mark it as such.
        Thanks,
        Hanan

        Show
        hl34125 added a comment - Chinmayee, Vipin reassigned the create-domain command to you. I believe this fix is already done in the mpage, but please verify and mark it as such. Thanks, Hanan
        Hide
        hl34125 added a comment -

        Chinmayee,

        Again, I believe this is fixed, but please confirm.
        Thanks,
        hanan

        Show
        hl34125 added a comment - Chinmayee, Again, I believe this is fixed, but please confirm. Thanks, hanan
        Hide
        km105526 added a comment -

        This is actually fixed much earlier, but the build b41 will definitely have it.

        Show
        km105526 added a comment - This is actually fixed much earlier, but the build b41 will definitely have it.
        Hide
        cs194067 added a comment -

        This has been fixed a while ago. Please check a newer build.

        Show
        cs194067 added a comment - This has been fixed a while ago. Please check a newer build.

          People

          • Assignee:
            cs194067
            Reporter:
            danbrice
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: