Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0
    • Component/s: cdi
    • Labels:
      None
    • Status Whiteboard:

      weld-int-required

      Show
      weld-int-required

      Description

      See: http://java.net/jira/browse/GLASSFISH-13182

      The application has beans.xml here:
      WEB-INF/classes/META-INF/beans.xml

      However, the GlassFish Weld Integration module expects beans.xml to be under WEB-INF:
      WEB-NF/beans.xml

      I haven't checked the Weld specification in a while, so if WEB-INF/classes/META-INF/beans.xml is a valid location,
      then the GlassFish Weld Integration module will have to be modified to accommodate this location.
      The workaround for now would be to just put beans.xml under WEB-INF directly:
      WEB-NF/beans.xml
      [ Show » ]
      rogerk added a comment - 06/Dec/10 11:49 AM Ok - the problem is as follows... The application has beans.xml here: WEB-INF/classes/META-INF/beans.xml However, the GlassFish Weld Integration module expects beans.xml to be under WEB-INF: WEB-NF/beans.xml I haven't checked the Weld specification in a while, so if WEB-INF/classes/META-INF/beans.xml is a valid location, then the GlassFish Weld Integration module will have to be modified to accommodate this location. The workaround for now would be to just put beans.xml under WEB-INF directly: WEB-NF/beans.xml

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            jjsnyder83
            Reporter:
            rogerk
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: