glassfish
  1. glassfish
  2. GLASSFISH-15039

warning in instances: connection refused on port 37676

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None

      Description

      Testing GlassFish v3.1 b32 promoted bundle.

      Attached are the DAS server.log and instance1 (ins1) server.log.

      Performed and upgrade of V2.1.1 cluster profile with 2 deployed apps and setup cluster of 2 instances ins1, ins2. The following WARNINGS show up in the instance log. Below is info from ins1 server.log:

      [#|2010-12-08T12:33:06.651-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]
      [#|2010-12-08T12:33:07.703-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]
      [#|2010-12-08T12:33:08.743-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]
      [#|2010-12-08T12:33:09.751-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]

      1. das.server.log
        21 kB
        adf59
      2. ins1.server.log
        16 kB
        adf59

        Activity

        Bobby Bissett added a comment -
        Bobby Bissett added a comment -

        Moving to JMS. If you check in domain.xml, you'll see this port is used by the jms provider. Do you see a similar warning in instance2 for port 37677?

        adf59 added a comment -

        Same WARNINGS in instance 2 log as well.

        Satish Kumar added a comment -

        This is not a bug. The warning messages are printed by JMSRA when its initial attempts to connect to the broker fail. The last message confirms that the connection has been established successfully - MQJMSRA_RA1101: SJSMQ JMSRA Started:LOCAL|#]

        It sometimes takes a few attempts for the RA to connect to the broker even in an non-upgraded setup and the same warnings are logged here as well.

        [#|2010-12-08T12:33:04.127-0500|INFO|glassfish3.1|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=14;_ThreadName=Thread-1;|MQJMSRA_RA1101: SJSMQ JMS Resource Adapter starting: broker is LOCAL, connection mode is TCP|#]

        [#|2010-12-08T12:33:06.651-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]

        [#|2010-12-08T12:33:07.703-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]

        [#|2010-12-08T12:33:08.743-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]

        [#|2010-12-08T12:33:09.751-0500|WARNING|glassfish3.1|javax.jms|_ThreadID=14;_ThreadName=Thread-1;|[C4003]: Error occurred on connection creation [localhost:37676]. - cause: java.net.ConnectException: Connection refused|#]

        [#|2010-12-08T12:33:15.387-0500|INFO|glassfish3.1|javax.resourceadapter.mqjmsra.lifecycle|_ThreadID=14;_ThreadName=Thread-1;|MQJMSRA_RA1101: SJSMQ JMSRA Started:LOCAL|#]

        adf59 added a comment -

        Bobby, yes those are the steps to follow:

        http://wikis.sun.com/display/GlassFish/V3.1ClusterUpgradeExample

        I have pre-canned configs already setup for testing but the initial setup follows the steps outlines in your wiki setup here.

        Bobby Bissett added a comment -

        Am only reopening so I can edit the summary to make this easier to find again. Then I'll close the issue.

        Bobby Bissett added a comment -

        Old summary: An upgrade of v2.1.1 cluster profile with 2 instances and 2 deployed apps shows WARNINGS in instance logs

        Bobby Bissett added a comment -

        Re-closing.


          People

          • Assignee:
            Satish Kumar
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: