Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b33
    • Component/s: web_container
    • Labels:
      None

      Description

      Given a cluster with instance inst1, inst2 and inst3,
      web container availability service and sso-failover are enabled.
      Also the corresponding user/password is set up for a given realm.
      Deploy a simple counter web app A and B with --availabilityenabled=true.

      Scenario 1 (Incorrect behavior):
      a) Access web app A in inst1, login and see the correct counter 0.
      And then access app B in inst1 without login and see the expected counter 0.
      b) stop-local-instance inst1
      c) Access web app B in inst2, without login, but the counter is 0 (which should be 1).
      Access web app A in inst2, without login, and see the expected counter 1.

      Scenario 2 (Correct behavior):
      a) Access web app A in inst1, login and see the correct counter 0.
      And then access app B in inst1 twice without login and see the expected counter 1.
      b) stop-local-instance inst1
      c) Access web app B in inst2, without login, and see the expected counter 2.
      Access web app A in inst2, without login, and see the expected counter 1.

      Both scenarios are working before.

        Activity

        Shing Wai Chan added a comment -

        With the recent shoal 1.5.23 integration, the issue is resolved.
        Per discussion with Mahesh, we would like to add a toString for debugging:

        — web/web-ha/src/main/java/org/glassfish/web/ha/authenticator/HASingleSignOnEntryMetadata.java (revision 43845)
        +++ web/web-ha/src/main/java/org/glassfish/web/ha/authenticator/HASingleSignOnEntryMetadata.java (working copy)
        @@ -131,4 +131,18 @@
        boolean removeHASessionData(HASessionData sessionData)

        { return sessionDataSet.remove(sessionData); }

        +
        + @Override
        + public String toString() {
        + return "HASingleSignOnEntryMetadata

        {" + + "id='" + id + '\'' + + ", authType='" + authType + '\'' + + ", sessionDataSet.size=" + sessionDataSet.size() + + ", username='" + username + '\'' + + ", realmName='" + realmName + '\'' + + ", lastAccessTime=" + lastAccessTime + + ", maxIdleTime=" + maxIdleTime + + ", version=" + version + + '}

        ';
        + }
        }

        Shing Wai Chan added a comment -

        Fix in shoal version 1.5.23.

        Checkin debug statement:
        Sending web/web-ha/src/main/java/org/glassfish/web/ha/authenticator/HASingleSignOnEntryMetadata.java
        Transmitting file data .
        Committed revision 43853.

        Nazrul added a comment -

        Approved for checkin


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            Shing Wai Chan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: