glassfish
  1. glassfish
  2. GLASSFISH-15093

Nucleus distribution is completely broken - can't start because of missing simple-glassfish-api.jar

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b31
    • Fix Version/s: 3.1_b33
    • Component/s: packaging
    • Labels:
      None

      Description

      I tried to run nucleus distro and it refuses to start:

      ss141213@Sahoo:/space/ss141213/WS/gf/v3$ java -jar
      /space/ss141213/WS/gf/v3/distributions/nucleus/target/stage/glassfish3/glassfish/modules/glassfish.jar

      Listening for transport dt_socket at address: 9009
      Launching GlassFish on Felix platform
      Exception in thread "main" java.lang.Error: java.io.IOException: No such
      file:
      /space/ss141213/WS/gf/v3/distributions/nucleus/target/stage/glassfish3/glassfish/modules/simple-glassfish-api.jar
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainHelper.createOSGiFrameworkLauncherCL(ASMainHelper.java:543)
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainHelper.createLauncherCL(ASMainHelper.java:508)
      at
      com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:92)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
      Caused by: java.io.IOException: No such file:
      /space/ss141213/WS/gf/v3/distributions/nucleus/target/stage/glassfish3/glassfish/modules/simple-glassfish-api.jar
      at
      com.sun.enterprise.glassfish.bootstrap.ClassPathBuilder.addJar(ClassPathBuilder.java:72)
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainHelper$ClassLoaderBuilder.addBootstrapApiJar(ASMainHelper.java:621)
      at
      com.sun.enterprise.glassfish.bootstrap.ASMainHelper.createOSGiFrameworkLauncherCL(ASMainHelper.java:539)
      ... 3 more

      The reason is simple: missing simple-glassfish-api.jar in modules/. When
      I look at various pom.xmls, I see it is part of web or glassfish distro
      probably because of a compile dependency on it from
      web/web-embed/api/pom.xml.

        Issue Links

          Activity

          Sanjeeb Sahoo added a comment -

          Fixed:
          ss141213@Sahoo:~/bugs/ACC-distro$ svn commit -m "Issue 15093: make simple-glassfish-api.jar part of all distro by adding a compile time dependency on it from glassfish.jar" !$
          svn commit -m "Issue 15093: make simple-glassfish-api.jar part of all distro by adding a compile time dependency on it from glassfish.jar" ~/WS/gf/v3/core/bootstrap/pom.xml
          Sending home/ss141213/WS/gf/v3/core/bootstrap/pom.xml
          Transmitting file data .
          Committed revision 43845.


            People

            • Assignee:
              Sanjeeb Sahoo
              Reporter:
              Sanjeeb Sahoo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: