glassfish
  1. glassfish
  2. GLASSFISH-15317

During asupgrade of cluster profile I get: No free port within range: 7676=com.sun.enterprise.v3.services.impl.ServiceInitializerHandler@57507544

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None
    • Environment:

      MAC OS X

      Description

      Testing using latest nightly latest-glassfish.zip for Dec-21-2010:

      Here is snippet from upgrade.log. I am attaching full server.log and upgrade.log.

      asadmin: java.net.BindException: No free port within range: 7676=com.sun.enterprise.v3.services.impl.ServiceInitializerHandler@57507544
      asadmin: at com.sun.grizzly.TCPSelectorHandler.initSelector(TCPSelectorHandler.java:432)
      asadmin: at com.sun.grizzly.TCPSelectorHandler.preSelect(TCPSelectorHandler.java:378)
      asadmin: at com.sun.grizzly.SelectorHandlerRunner.doSelect(SelectorHandlerRunner.java:188)
      asadmin: at com.sun.grizzly.SelectorHandlerRunner.run(SelectorHandlerRunner.java:13
      2)
      asadmin: at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecut
      or.java:886)
      asadmin: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      asadmin: at java.lang.Thread.run(Thread.java:680)
      asadmin: |#]
      asadmin: [

      1. server.log.during.upgrade
        13 kB
        adf59
      2. upgrade.log
        8 kB
        adf59

        Activity

        Bobby Bissett added a comment -

        The 7676 port is used by jms. Am assigning there for initial look.

        adf59 added a comment -

        After upgrade I am unable to start the domain after this error.

        Bobby Bissett added a comment -

        I downloaded http://dlc.sun.com.edgesuite.net/glassfish/3.1/nightly/glassfish-3.1-b34-12_21_2010.zip and unable to reproduce the issue with the updomain that is in the admin dev tests. Can you make sure you really have nothing running on 7676 and try again? If you still see the issue, can you share what steps you took to reproduce it?

        Also, what do you mean that you can't start the domain after this? Is it the same error or something else?

        Bobby Bissett added a comment -

        Can't reproduce in the specified build either with asadmin or asupgrade. It's also working for me in the trunk and I haven't seen any cluster upgrade test failures in the continuous build lately.

        Bobby Bissett added a comment -

        Art, one thing you can check is the host name jms is using in domain.xml. Maybe you installed v2.X on a machine with one host name and are trying to do the upgrade with another. This may work sometimes (jms won't work, but the upgrade will). But if someone with that host name is running something on port 7676 then you won't be able to connect to it. Look for 'jms-host' in domain.xml (and check other hosts as well – for repeatable upgrade testing on different systems, I change the host values tp "localhost").

        adf59 added a comment -

        Bobby, you are right on. I just checked and low-and-behold my dhcp name which was always constant recently changed. The current dhcp hostname does not match what was in the v2 setup I created several months ago.
        I just recreated the v2 setup and redid this and not port 7676 issue this time.

        adf59 added a comment -

        Closing this issue out. The create v2 domain had hostnames that differed than the one being upgraded to due to dhcp name being changed. So this is no longer an issue.


          People

          • Assignee:
            adf59
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: