glassfish
  1. glassfish
  2. GLASSFISH-15441

[UB]org.osgi.framework.BundleException during shutdown after upgrade

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: None
    • Component/s: docs
    • Labels:
      None
    • Environment:

      Solaris 10 Sparc

      Description

      During asupgrade to upgrade a V2.1.1 developer profile with a deployed webapp I am seeing the following error
      from upgrade.log (full log added as attachment):

      asadmin: Error while starting bundle: file:/sun/glassfishv2.1.1/glassfish3/glassfish/modules/autostart/org.apache.felix.bundlerepository.jar: org.osgi.framework.BundleException: Cannot start bundle org.apache.felix.bundlerepository [244] because its start level is 1, which is greater than the framework's start level of 0.
      asadmin: org.osgi.framework.BundleException: Cannot start bundle org.apache.felix.bundlerepository [244] because its start level is 1, which is greater than the framework's start level of 0.
      asadmin: at org.apache.felix.framework.Felix.startBundle(Felix.java:1690)
      asadmin: at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
      asadmin: at org.apache.felix.fileinstall.internal.DirectoryWatcher.start(DirectoryWatcher.java:1136)
      asadmin: at org.apache.felix.fileinstall.internal.DirectoryWatcher.start(DirectoryWatcher.java:1122)
      asadmin: at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1115)
      asadmin: at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:433)
      asadmin: at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:241)

      1. server.log
        12 kB
        adf59
      2. upgrade.log
        20 kB
        adf59
      3. upgrade.log
        20 kB
        adf59

        Activity

        Tom Mueller added a comment -

        Bobby, can you please take a look at this to figure out where this belongs?

        Bobby Bissett added a comment -

        Art,

        Can you give me more info on this? What build are you trying, and is there any info about the app?

        Bobby Bissett added a comment -

        All the upgrade tests are passing – does the server still work after you see this?

        adf59 added a comment -

        Build tested was latest nightly glassfish bundle dated jan 5.

        The server starts up fine and the helloworld web
        app is reachable.

        I just happen to see this error during the asupgrade and filed the bug.

        I upgraded a developer profile with HelloWorldApp deployed.

        Bobby Bissett added a comment -

        It took me several tries to reproduce this, and now I can't reproduce again. I suspect that those warnings are always happening, but there is a timing issue with whether or not they're logged.

        Can you attach the server log also?

        adf59 added a comment -

        It happens consistently with me. I am on a Solaris 10 Sparc system.

        I am attaching the server.log.

        adf59 added a comment -

        server.log and upgrade.log attached.

        Bobby Bissett added a comment -

        I've had to go to the dev list about this one:
        http://java.net/projects/glassfish/lists/dev/archive/2011-01/message/38

        Art, since this happens every time for you, can you start/stop the domain and see if you see the same error?

        Bobby Bissett added a comment -

        Since this happens during a shutdown, and doesn't affect startup or use of the app server after the upgrade, I'm downgrading this to a P4. But I'd still like to find out what it means and whether it needs to be fixed or documented.

        adf59 added a comment -

        A stop and start of server does not show anything unusual. Everything looked fine. It appears you see this during the upgrade.

        Bobby Bissett added a comment -

        Am moving this over to docs. I've been talking with Richard Hall about this, and there's a chance it could be fixed by Sahoo. When I get more information, I'll attach it here. If the situation stays the same, then we should document that in some cases users will see these errors at the end of an upgrade. It happens during shutdown of the server and doesn't affect anything else.

        I don't know if it's material for the upgrade guide, release notes, etc.

        Bobby Bissett added a comment -

        I've heard from Sahoo that the issue won't be fixed for 3.1. GLASSFISH-15519 captures the error messages and explanation. This issue affects the server whenever it's started with the --verbose flag. Because the --upgrade flag implies the --verbose flag, that's why we're seeing it at the end of upgrades.

        So this information may need to be documented somewhere more general than some upgrade-specific documentation.

        (Side note: these error messages have always been present, but only showed up recently due to logging changes.)

        Bobby Bissett added a comment -

        Changing summary from:

        asadmin error during asupgrade of a developer profile with deployed app

        to:

        org.osgi.framework.BundleException during shutdown after upgrade

        Scott Fordin added a comment -

        Not sure if this should go in the Release Notes or in the Upgrade Guide proper. Any opinions?

        Bobby Bissett added a comment -

        I guess the release notes make more sense. It doesn't always happen, which is good, so I'm hoping no one even sees it on nice, fast production systems.

        Scott Fordin added a comment -

        Added topic to 3.1 Release Notes.

        Scott Fordin added a comment -

        Added "3_1-release-note-added" tag.


          People

          • Assignee:
            Scott Fordin
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: