glassfish
  1. glassfish
  2. GLASSFISH-15482

Domain fails to stop after console loaded (with secure admin enabled)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 3.1_b36
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None
    • Environment:

      S11/x86

      Description

      Server fails to stop when in secure admin mode and Console has been loaded.

      To reproduce this problem:

      1) Install b36
      2) start-domain
      3) enabled-secure-admin
      4) stop-domain
      5) start-domain
      6) load Admin Console
      7) stop-domain

      In step 7 asadmin will report:

      ouch: ./asadmin stop-domain
      CLI306 Warning - server is not running.
      Command stop-domain executed successfully.

      and the following will be in the server log:

      [#|2011-01-07T11:46:15.563-0800|WARNING|oracle-glassfish3.1|com.sun.grizzly.config.GrizzlyServiceListener|_ThreadID=24;_ThreadName=admin-thread-pool-4848(5);|processorTask.exceptionSSLcert
      javax.net.ssl.SSLHandshakeException: renegotiation is not allowed
      at com.sun.net.ssl.internal.ssl.SSLEngineImpl.kickstartHandshake(SSLEngineImpl.java:621)
      at com.sun.net.ssl.internal.ssl.SSLEngineImpl.beginHandshake(SSLEngineImpl.java:667)
      at com.sun.grizzly.util.SSLUtils.doPeerCertificateChain(SSLUtils.java:559)
      at com.sun.grizzly.filter.SSLReadFilter.doPeerCertificateChain(SSLReadFilter.java:340)
      at com.sun.grizzly.ssl.SSLProcessorTask.action(SSLProcessorTask.java:153)
      at com.sun.grizzly.tcp.Request.action(Request.java:430)
      at com.sun.grizzly.tcp.http11.GrizzlyRequest.getAttribute(GrizzlyRequest.java:835)
      at com.sun.grizzly.tcp.http11.GrizzlyRequest.getUserPrincipal(GrizzlyRequest.java:1834)
      at com.sun.enterprise.v3.admin.AdminAdapter.authenticate(AdminAdapter.java:266)
      at com.sun.enterprise.v3.admin.AdminAdapter.authenticate(AdminAdapter.java:309)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:218)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:818)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1008)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:619)

      #]

      [#|2011-01-07T11:46:15.569-0800|SEVERE|oracle-glassfish3.1|com.sun.grizzly.config.GrizzlyServiceListener|_ThreadID=24;_ThreadName=admin-thread-pool-4848(5);|service exception
      java.lang.RuntimeException: ClientAbortException: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:254)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:818)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1008)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: ClientAbortException: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.doFlush(GrizzlyOutputBuffer.java:439)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.flush(GrizzlyOutputBuffer.java:405)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputStream.flush(GrizzlyOutputStream.java:140)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:251)
      ... 17 more
      Caused by: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.grizzly.util.SSLOutputWriter.flushChannel(SSLOutputWriter.java:98)
      at com.sun.grizzly.ssl.SSLOutputBuffer.flushChannel(SSLOutputBuffer.java:138)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flushBuffer(SocketChannelOutputBuffer.java:398)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flush(SocketChannelOutputBuffer.java:376)
      at com.sun.grizzly.http.ProcessorTask.action(ProcessorTask.java:1236)
      at com.sun.grizzly.ssl.SSLProcessorTask.action(SSLProcessorTask.java:164)
      at com.sun.grizzly.tcp.Response.action(Response.java:268)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.doFlush(GrizzlyOutputBuffer.java:434)
      ... 20 more

      #]

      [#|2011-01-07T11:46:45.592-0800|WARNING|oracle-glassfish3.1|com.sun.grizzly.config.GrizzlyServiceListener|_ThreadID=22;_ThreadName=admin-thread-pool-4848(4);|processorTask.exceptionSSLcert
      javax.net.ssl.SSLHandshakeException: renegotiation is not allowed
      at com.sun.net.ssl.internal.ssl.SSLEngineImpl.kickstartHandshake(SSLEngineImpl.java:621)
      at com.sun.net.ssl.internal.ssl.SSLEngineImpl.beginHandshake(SSLEngineImpl.java:667)
      at com.sun.grizzly.util.SSLUtils.doPeerCertificateChain(SSLUtils.java:559)
      at com.sun.grizzly.filter.SSLReadFilter.doPeerCertificateChain(SSLReadFilter.java:340)
      at com.sun.grizzly.ssl.SSLProcessorTask.action(SSLProcessorTask.java:153)
      at com.sun.grizzly.tcp.Request.action(Request.java:430)
      at com.sun.grizzly.tcp.http11.GrizzlyRequest.getAttribute(GrizzlyRequest.java:835)
      at com.sun.grizzly.tcp.http11.GrizzlyRequest.getUserPrincipal(GrizzlyRequest.java:1834)
      at com.sun.enterprise.v3.admin.AdminAdapter.authenticate(AdminAdapter.java:266)
      at com.sun.enterprise.v3.admin.AdminAdapter.authenticate(AdminAdapter.java:309)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:218)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:818)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1008)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:619)

      #]

      [#|2011-01-07T11:46:45.594-0800|SEVERE|oracle-glassfish3.1|com.sun.grizzly.config.GrizzlyServiceListener|_ThreadID=22;_ThreadName=admin-thread-pool-4848(4);|service exception
      java.lang.RuntimeException: ClientAbortException: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:254)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:168)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:117)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:234)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:818)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:719)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1008)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: ClientAbortException: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.doFlush(GrizzlyOutputBuffer.java:439)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.flush(GrizzlyOutputBuffer.java:405)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputStream.flush(GrizzlyOutputStream.java:140)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:251)
      ... 17 more
      Caused by: java.io.IOException: SSLOutputWriter: CLOSED
      at com.sun.grizzly.util.SSLOutputWriter.flushChannel(SSLOutputWriter.java:98)
      at com.sun.grizzly.ssl.SSLOutputBuffer.flushChannel(SSLOutputBuffer.java:138)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flushBuffer(SocketChannelOutputBuffer.java:398)
      at com.sun.grizzly.http.SocketChannelOutputBuffer.flush(SocketChannelOutputBuffer.java:376)
      at com.sun.grizzly.http.ProcessorTask.action(ProcessorTask.java:1236)
      at com.sun.grizzly.ssl.SSLProcessorTask.action(SSLProcessorTask.java:164)
      at com.sun.grizzly.tcp.Response.action(Response.java:268)
      at com.sun.grizzly.tcp.http11.GrizzlyOutputBuffer.doFlush(GrizzlyOutputBuffer.java:434)
      ... 20 more

      #]

        Activity

        Chris Kasso created issue -
        Chris Kasso made changes -
        Field Original Value New Value
        Summary Domain fails to stop after console loaded (with secure admin is enabled) Domain fails to stop after console loaded (with secure admin enabled)
        Tom Mueller added a comment -

        This appears to be due to running with a JDK that is less than version 1.6.0_22.
        Can you please check this?

        Tom Mueller made changes -
        Assignee Tom Mueller [ tmueller ] Chris Kasso [ kasso ]
        Nazrul added a comment -

        This is most likely due to JDK update 22 issue. Lowering the priority. If we have a problem with update 22, please raise the priority.

        Nazrul made changes -
        Priority Critical [ 2 ] Minor [ 4 ]
        Chris Kasso added a comment -

        I was using 21. I upgraded to 23 and the problem is not reproducible. I've marked this issues with 3_1-release-notes to ensure we stress that bad things can happen in update 21 or earlier is used. (I suspect this is already stressed in the docs).

        Chris Kasso made changes -
        Priority Minor [ 4 ] Critical [ 2 ]
        Tags 3_1-release-notes
        Chris Kasso made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Scott Fordin made changes -
        Tags 3_1-release-notes 3_1-release-note-added 3_1-release-notes
        Scott Fordin added a comment -

        Issue added to 3.1 Release Notes.


          People

          • Assignee:
            Chris Kasso
            Reporter:
            Chris Kasso
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: