glassfish
  1. glassfish
  2. GLASSFISH-15516

show "restart required" status when JMS ports are changed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1_b37
    • Fix Version/s: 3.1
    • Component/s: jms
    • Labels:
      None

      Description

      Admin Console - Go to Configurations - server-config - Java Message Service - JMS Hosts - Port - 7678 - Save

      1. The console main screen doesn't show "restart required" status for the server.

      2. CLI doesn't show the 'restart required' status either.
      csh% asadmin list-domains
      domain1 running

      The new JMS port doesn't take effect until the server is restarted.

      http://docs.sun.com/app/docs/doc/821-1751/gitzw

        Activity

        Anissa Lam added a comment -

        You can also try the hidden command that GUI uses to ensure that GUI notifies user correctly.

        %asadmin _get-restart-required

        >>2. CLI doesn't show the 'restart required' status either.
        I don't think this is a GUI bug then, transfer to 'admin'

        Tom Mueller added a comment -

        I was able to reproduce this too. It appears that there is no UnprocessedChangeEvent being produced for this change.

        Nazrul added a comment -

        Restart required feature is used by users and customers. We should fix this.

        Nazrul added a comment -

        1. How bad is its impact? (Severity)
        Critical. If not fixed, this could lead to customer escalations.

        2. How often does it happen? (Frequency)
        This occurs when changes are made to the jms-host element either through admin console or CLI.

        3. How much effort is required to fix it? (Cost)
        Moderate. This requires a few changes to the JMS module to handle config changes to the JMSHost server bean.

        4. What is the risk of fixing it? (Risk)
        Low.

        5. Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?

        No, there is no workaround for this issue.

        6. If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?

        Yes, if this issue is not fixed, it needs to be release noted.

        Satish Kumar added a comment -

        Requesting for GF CC approval:

        Component: JMS
        Issue: http://java.net/jira/browse/GLASSFISH-15516

        1. How bad is its impact? (Severity)
        Critical. If not fixed, this could lead to customer escalations.

        2. How often does it happen? (Frequency)
        This occurs when changes are made to the jms-host element either through admin console or CLI.

        3. How much effort is required to fix it? (Cost)
        Moderate. This requires a few changes to the JMS module to handle config changes to the JMSHost server bean.

        4. What is the risk of fixing it? (Risk)
        Low.

        5. Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?

        No, there is no workaround for this issue.

        6. If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?

        Yes, if this issue is not fixed, it needs to be release noted.

        Satish Kumar added a comment -

        Added a config listener to listen for changes to the JMSHost serverbean. Changes to JMSHost are not dynamic and require a restart for the changes to take effect. Also, the JMSConfigListener is now initialized by the JMSProviderLifecycle for the listener to be available even if MQ has not been started

        Harshad Vilekar added a comment -

        Verified: 3.1 B39.


          People

          • Assignee:
            Satish Kumar
            Reporter:
            Harshad Vilekar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: