glassfish
  1. glassfish
  2. GLASSFISH-15534

Http Status 404 shown when JVM settings/Path Settings Cancel button is clicked.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b36
    • Fix Version/s: 3.1_b38
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      env: Windows 2008 Server
      Browser: IE and firefox 3.6

      Description

      GF Build used : nightly dated b37-01-11-2011
      In the Console click on the Cancel button in the server-config/JVM Settings/Path Settings Page.

      The below 404 Status is thrown.

      HTTP Status 404 -

      type Status report

      message

      descriptionThe requested resource () is not available.
      Oracle GlassFish Server 3.1

        Activity

        Anissa Lam added a comment -

        There should not be any Cancel button on this page. There isn't a 'list' page for this page to go back to, so according to the GUI convention, the cancel button shouldn't be there.

        How bad is its impact? (Severity)
        Very unprofessional to show a 404 on screen.

        How often does it happen? (Frequency)
        Everytime when user goes to the JVM Path page and then click the Cancel button.

        How much effort is required to fix it? (Cost)
        1 hour

        What is the risk of fixing it? (Risk)
        no risk. Just remove the button.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        No. it won't help.

        ~/Awork/V3/v3/admingui 153) svn diff common

        Index: common/src/main/resources/javaConfig/jvmPath_2.inc
        ===================================================================
        — common/src/main/resources/javaConfig/jvmPath_2.inc (revision 44400)
        +++ common/src/main/resources/javaConfig/jvmPath_2.inc (working copy)
        @@ -73,12 +73,6 @@
        gf.redirect(page="#

        {selfPage}

        &alertType=$

        {alertType}

        &alertSummary=$

        {alertSummary}

        &alertDetail=$

        {alertDetail}

        ");
        />
        </sun:button>
        -

        • <sun:button id="cancelButton" immediate="# {true}

          " primary="#

          {false}

          " rendered="#

          {pageSession.showCancelButton}

          " text="$resource

          {i18n.button.Cancel}

          " >

        • <!command
        • gf.redirect(page="# {parentPage}

          ?configName=#

          {configName}

          ");

        • />
        • </sun:button>
          </sun:panelGroup>
          </facet>
        Anissa Lam added a comment -

        Project: glassfish
        Repository: svn
        Revision: 44417
        Author: anilam
        Date: 2011-01-12 07:28:29 UTC
        Link:

        Log Message:
        ------------
        Fix GLASSFISH-15534. Remove the Cancel button from JVM Path page. It shouldn' be there at all.

        Approved: self-approve
        Reviewer: Suma, Srini

        Revisions:
        ----------
        44417

        Modified Paths:
        ---------------
        trunk/v3/admingui/common/src/main/resources/javaConfig/jvmPath_2.inc

        shaline added a comment -

        verified on promoted b38.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: