glassfish
  1. glassfish
  2. GLASSFISH-15586

Parameter associate-with-thread fails when activated for more than one pool

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: jdbc
    • Labels:
      None

      Description

      Raising this issue for 3.1 release.

      Original issue : GLASSFISH-15577
      http://java.net/jira/browse/GLASSFISH-15577

      Refer the original issue for more details.

        Activity

        Jagadish added a comment -

        Yes, this is an issue. It seems that the thread-local is declared as static for the pool which is incorrect. It should be declared per instance of pool.

        Jagadish added a comment -

        1. How bad is its impact? (Severity)

        • Identify why the fix needs to occur now:
          o Likely to generate a customer support call
          o An in-your-face issue that will touch the majority of users
          2. How often does it happen? (Frequency)
        • When more than one jdbc-connection-pool has "associate-with-thread" flag enabled.
          3. How much effort is required to fix it? (Cost)
        • Simple, instead of using static thread-local variable, use per instance thread-local.
          4. What is the risk of fixing it? (Risk)
        • None, fix is localized to associate-with-thread.
        • All tests passed : QL (Web, Classic), connector-dev, jdbc-dev, connector-standalone-cts (Web, Classic), resources-admin-cli, connector-sqe
        • Will also be adding a new test-case for this particular scenario in jdbc dev-tests.
          5. Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        • No workaround other then disabling the flag altogether.
          6. If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        • NA
        Jagadish added a comment -

        svn log -v -r 44526

        Modified Paths:
        ---------------
        trunk/v3/connectors/connectors-runtime/src/main/java/com/sun/enterprise/resource/pool/AssocWithThreadResourcePool.java

        marsangr added a comment -

        I can reproduce the problem in Glassfish Open Source Edition 2.1.1
        Could somebody apply the same patch to it?


          People

          • Assignee:
            Jagadish
            Reporter:
            Jagadish
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: