glassfish
  1. glassfish
  2. GLASSFISH-15597

INFO message showing NullPointerException logged on cluster instance start

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b39
    • Component/s: OSGi
    • Labels:
      None
    • Environment:

      Solaris Sparc

      Description

      Testing latest nightly GlassFish 3.1 bundle dated Jan 18.

      I performed an upgrade of a Cluster profile V2.1.1 release with 2 deployed apps.

      Through Admin GUI I listed cluster instances and selected instance 1. Next I hit stop to stop ins1. Next I hit start to start ins1. It started and it shows it in the GUI but looking at ins1 server log I see the following NullPointerException being logged as an INFO message (I included full instance server log):

      [#|2011-01-18T15:52:52.841-0500|INFO|glassfish3.1|javax.enterprise.system.std.co
      m.sun.enterprise.server.logging|_ThreadID=12;_ThreadName=Thread-1;|/sun/glassfis
      hv2.1.1/glassfish3/glassfish/nodes/na1/ins1/autodeploy/bundles does not exist, p
      lease create it.|#]

      [#|2011-01-18T15:52:52.856-0500|INFO|glassfish3.1|javax.enterprise.system.std.co
      m.sun.enterprise.server.logging|_ThreadID=98;_ThreadName=Thread-1;|In main loop,
      we have serious trouble: java.lang.NullPointerException|#]

      [#|2011-01-18T15:52:52.859-0500|INFO|glassfish3.1|javax.enterprise.system.std.co
      m.sun.enterprise.server.logging|_ThreadID=98;_ThreadName=Thread-1;|java.lang.Nul
      lPointerException
      at org.apache.felix.fileinstall.internal.FileInstall.getStartLevel(FileI
      nstall.java:283)
      at org.apache.felix.fileinstall.internal.FileInstall.getStartLevel(FileI
      nstall.java:276)
      at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryW
      atcher.java:237)

      #]
      1. b38-das-server.log
        89 kB
        adf59
      2. das.log
        115 kB
        adf59
      3. server.log
        19 kB
        adf59

        Activity

        adf59 added a comment -

        Great! I'm glad the test system was of use to you and it helped pinpoint down the problem with this issue.

        Sanjeeb Sahoo added a comment -

        How bad is its impact? (Severity): High

        • Likely to generate a customer support call
        • An in-your-face issue that will touch the majority of users

        How often does it happen? (Frequency): On some multi-core systems, quite often

        How much effort is required to fix it? (Cost): Medium

        What is the risk of fixing it? (Risk): Low

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?: NA

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?: NA

        Sanjeeb Sahoo added a comment -

        This will require a new integration of Felix File Install. See https://issues.apache.org/jira/browse/FELIX-2791 . I have already started the voting process for FileInstall 3.1.6 and it will take at least 3 days before we can release the bits there.

        Chris Kasso added a comment -

        Approved for 3.1.

        Sanjeeb Sahoo added a comment -

        ss141213@Sahoo:/space/ss141213/WS/gf/v3$ svn commit -m "Issue 15597: Integrated FileInstall 3.1.6 to avoid NPE caused by race condition. See JIRA for change control process." osgi-platforms/felix/pom.xml
        Sending osgi-platforms/felix/pom.xml
        Transmitting file data .
        Committed revision 44695.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            adf59
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: