Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.1_b38
    • Fix Version/s: 3.1_b39
    • Component/s: admin_gui
    • Labels:
      None

      Description

      Go to:

      Admin Console | Configurations | default-config | EJB Container | EJB Settings | Commit Options | Option B:

      This item is labelled with:

      AAAAAThe container caches a ready instance between transactions, ...

      By the way, there's Option B and Option C, but what about Option A?

        Activity

        Anissa Lam added a comment -

        This 'AAAAA' is probably accidentally left behind during debugging. We should fix this.

        How bad is its impact? (Severity)
        No Impact. But it is very embarrassing and unprofessional to have this on the screen.

        How often does it happen? (Frequency)
        Everytime when user goes to the EJB Settings page, they will see this.

        How much effort is required to fix it? (Cost)
        min. just remove the 'AAAAA' from the static text.

        What is the risk of fixing it? (Risk)
        no risk.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No workaround, user will always see this.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        no.

        svn diff:
        ~/Awork/V3/v3/admingui/ejb-lite 39) svn diff
        Index: src/main/resources/configuration/ejbContainerGeneral.jsf
        ===================================================================
        — src/main/resources/configuration/ejbContainerGeneral.jsf (revision 44647)
        +++ src/main/resources/configuration/ejbContainerGeneral.jsf (working copy)
        @@ -93,7 +93,7 @@
        <sun:radioButton id="optB" name="commitOptGrp" label="$resource

        {i18n_ejbLite.ejbSettings.optB}

        " selected="#

        {pageSession.valueMap['commitOption']}" selectedValue="B"
        onClick="document.getElementById('form1:option').value='B';"
        />
        - <sun:helpInline id="optBHelpText" style="padding: 4pt" style="font-size: 8pt" text="AAAAA$resource{i18n_ejbLite.ejbSettings.optBHelp}"/>
        + <sun:helpInline id="optBHelpText" style="padding: 4pt" style="font-size: 8pt" text="$resource{i18n_ejbLite.ejbSettings.optBHelp}"/>
        "<br />
        <sun:radioButton id="optC" name="commitOptGrp" label="$resource{i18n_ejbLite.ejbSettings.optC}" selected="#{pageSession.valueMap['commitOption']}

        " selectedValue="C"
        onClick="document.getElementById('form1:option').value='C';"

        Anissa Lam added a comment -

        To answer the question about commit-option. There is only option B and option C ever since v2.
        Here is the dtd for v2, and the config bean in v3 follows the same.

        <!ATTLIST ejb-container
        ...
        commit-option (B | C) "B"
        session-store CDATA #IMPLIED
        >

        Anissa Lam added a comment -

        Project: glassfish
        Repository: svn
        Revision: 44678
        Author: anilam
        Date: 2011-01-24 04:44:44 UTC
        Link:

        Log Message:
        ------------
        GLASSFISH-15661. Remove the text 'AAAAA' in the helptext which is left behind from debugging.

        Approve: Anissa
        Reviewer: Srini

        Revisions:
        ----------
        44678

        Modified Paths:
        ---------------
        trunk/v3/admingui/ejb-lite/src/main/resources/configuration/ejbContainerGeneral.jsf


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Harald Wellmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: