glassfish
  1. glassfish
  2. GLASSFISH-15662

Admin Console: Wrong message on JMS Ping

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b38
    • Fix Version/s: 3.1_b39
    • Component/s: admin_gui
    • Labels:
      None

      Description

      Go to Admin Console | Configurations | default-config | Java Message Service and click on Ping.

      A yellow message banner appears:

      Expected message: Ping succeeded
      Actual message: New values successfully saved.

      Besides, the page title should read Java Message Service (not JMS Service) to match the tree item in the left-hand panel.

        Activity

        Anissa Lam added a comment -

        I am changing this to a P3, and would like Jason to take a look.
        We should give feedback correctly to user whether the Ping success or Fail.

        Harshad Vilekar added a comment -

        Note: JMS ping incorrect message is specific to "default-config". It shows correct message "Ping Succeeded" under cluster-config and server-config.

        Jason Lee added a comment -

        Attempting to ping the JMS broker for the default config doesn't make sense, as there's no server (and, hence, no broker) associated with the config, so there's nothing to ping. That being so, I'm removing the ping button from the default-config page.

        How bad is its impact? (Severity)
        Very minor. The issue here is simply misleading or confusing feedback, which can lead to quality perception issues.

        How often does it happen? (Frequency)
        Every time

        How much effort is required to fix it? (Cost)
        Very little

        What is the risk of fixing it? (Risk)
        Almost none

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        Perhaps. As explained, the use of this button on the default-config page doesn't make sense, so the "workaround" is probably "Don't do that!"

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        It wouldn't hurt, but I can't imaging this is a common problem.

        Svn diff:

        Index: admingui/jms-plugin/src/main/resources/org/glassfish/jms/admingui/Strings.properties
        ===================================================================
        — admingui/jms-plugin/src/main/resources/org/glassfish/jms/admingui/Strings.properties (revision 44710)
        +++ admingui/jms-plugin/src/main/resources/org/glassfish/jms/admingui/Strings.properties (working copy)
        @@ -65,7 +65,7 @@

        1. JMS Service
          #
          jms.ResourcesPageTitle=JMS Resources
          -jms.Title=JMS Service
          +jms.Title=Java Message Service
          jms.PageHelp=General properties for the Java Message Service (JMS) service apply only to the application server's default JMS provider, GlassFish Message Queue. All other messaging providers that are plugged into the application server via resource adapters can be configured through the Connector Resources screens.
          jms.Type=Type:
          jms.TypeHelp=Whether JMS Service is on local or remote system
          Index: admingui/jms-plugin/src/main/resources/jmsService.jsf
          ===================================================================
            • admingui/jms-plugin/src/main/resources/jmsService.jsf (revision 44710)
              +++ admingui/jms-plugin/src/main/resources/jmsService.jsf (working copy)
              @@ -85,6 +85,7 @@
              <sun:title id="propertyContentPage" title="$resource {i18njms.jms.Title}

              " helpText="$resource

              {i18njms.jms.PageHelp}

              ">
              #include "/common/shared/editPageButtons.inc"
              <sun:button id="pingButton" text="$resource

              {i18njms.jms.Ping}

              "
              + rendered="#

              {pageSession.configName != 'default-config'}

              "
              onClick="return submitAndDisable(this, '$resource

              {i18n.button.Processing}

              ');" >
              <!command
              prepareSuccessfulMsg();

        sirajg added a comment -

        Changes look good

        Jason Lee added a comment -

        Fix committed (r44724)


          People

          • Assignee:
            Jason Lee
            Reporter:
            Harald Wellmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: