Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b38
    • Fix Version/s: 3.1_b40
    • Component/s: admin_gui
    • Labels:
      None

      Description

      The Documentation links on the Common Tasks welcome page are broken. They all link or redirect to http://www.oracle.com/pls/topic/error.

        Activity

        Anissa Lam added a comment -

        The link points to 3.1 doc set is correct. But according to the doc team, the page will not come alive till 3.1 ships. I don't need this arrangement either.

        Transfer to 'doc' team. They can verify the link one more time and mark resolve.

        Doc links for 3.1
        commonTasks.doc.qstart=http://www.oracle.com/pls/topic/lookup?ctx=821-2432
        commonTasks.doc.adminGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2416
        commonTasks.doc.devGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2418
        commonTasks.doc.deployGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2417

        Paul Davies added a comment -

        If engineering feels uneasy about linking to documentation that will not be live until the product is released, all I can suggest is that the links be removed from the software.

        Paul Davies added a comment -

        After checking again with the doc tools team, I have discovered that the URLs that I was originally given were incorrect:

        The correct URLs are as follows:

        commonTasks.doc.qstart=http://www.oracle.com/pls/topic/lookup?ctx=821-2432&id=sjsaseeqsg
        commonTasks.doc.adminGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2416&id=sjsaseeag
        commonTasks.doc.devGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2418&id=sjsaseedg
        commonTasks.doc.deployGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2417&id=sjsaseeadg

        Note that the targets of these corrected URLs will not be live until the product ships and will continue to return an error until then.

        Paul Davies added a comment -

        Assigned to owner of admin_gui for fixing.

        Anissa Lam added a comment -

        How bad is its impact? (Severity)
        Very severe. User will not be able to get to the documentation from admin conole.

        How often does it happen? (Frequency)
        Whenever user clicks the doc link in the common task page.

        How much effort is required to fix it? (Cost)
        1 hour

        What is the risk of fixing it? (Risk)
        changing this link is not risky, it is in the i18n string file.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No workaround.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        Yes

        Index: core/src/main/resources/org/glassfish/admingui/core/Strings.properties
        ===================================================================
        — core/src/main/resources/org/glassfish/admingui/core/Strings.properties (revision 44647)
        +++ core/src/main/resources/org/glassfish/admingui/core/Strings.properties (working copy)
        @@ -400,10 +400,11 @@

        1. change the doc link to the localized copy if there is any
          -commonTasks.doc.qstart=http://www.oracle.com/pls/topic/lookup?ctx=821-2432
          -commonTasks.doc.adminGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2416
          -commonTasks.doc.devGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2418
          -commonTasks.doc.deployGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2417
          +commonTasks.doc.qstart=http://www.oracle.com/pls/topic/lookup?ctx=821-2432&id=sjsaseeqsg
          +commonTasks.doc.adminGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2416&id=sjsaseeag
          +commonTasks.doc.devGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2418&id=sjsaseedg
          +commonTasks.doc.deployGuide=http://www.oracle.com/pls/topic/lookup?ctx=821-2417&id=sjsaseeadg
          +
        2. end Common Tasks keys

        #common

        Anissa Lam added a comment -

        Committed revision 44741.
        Revision: 44741
        Author : anilam
        Date : Jan 27, 2011 8:49:41 AM
        GLASSFISH-15663. Fix the link to the unbundled doc on common task page.

        Approve: Anissa
        Reviewer: Paul Davies.

        stephanj added a comment -

        The glassfish install summary HTML file shows many links to http://docs.sun.com/doc/820-7690 which are broken.

        scatari added a comment -

        Paul,
        Can u provide us with the updated URL for Install Guide(online)? Are we not setting redirects for these links?

        Thanks

        Anissa Lam added a comment -

        This bug has been resolved, and not related to installation summary HTML file at all.
        I have opened http://java.net/jira/browse/GLASSFISH-15782 for that.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Harald Wellmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: