glassfish
  1. glassfish
  2. GLASSFISH-15686

using "configure-jms-cluster" in a non-recommended way could leave the system in inconsistent state

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b38
    • Fix Version/s: 4.1
    • Component/s: jms
    • Labels:
      None
    • Environment:

      tested on Oracle Enterprise Linux 5 (but the issue is platform independent)

      Description

      • Create a glassfish cluster
      • Create instances
      • use configure-jms-cluster to configure the cluster not to use Master Broker
        The command printed the following warning.

      "WARNING: Please ensure that you have followed the instructions specified in the documentation before running this command with this option. Running this command without the required precautions can lead to inconsistent JMS behavior and corruption of configuration and message stores."

      The above warning message doesn't say much. There is no way one would know what is wrong. The command doesn't mention that there are instances associated with the cluster and the command need to be executed before creating the instances.

      Above all, the command executed and returned successfully.

      When the test started the glassfish cluster after this command, the MQ Broker on two of the glassfish instances started with no master broker option and the MQ Broker on the third glassfish instance started with Master Broker Option. The third broker was waiting indefinitely to sync up with the Master Broker. it doesn't happen on all the systems. but can be consistently reproduced on the systems on which it shows up.

      command probably should stop executing if it detects the conditions are not met and print clear messages, rather than leaving the system in insistent state.

        Activity

        Nazrul added a comment -

        Not a stopper. Excluding from 3.1 count.

        Satish Kumar added a comment -

        This is not a bug but a RFE request.

        While the consequences of running this command on an existing cluster are well documented, there is potential to make this command more intelligent and handle error conditions betters. However, this work is out-of-scope for the 3.1.* release and would be looked at as a enhancement request in a later release. Hence marking this issue as 3_1-next.

        Satish Kumar added a comment -

        Downgrading the priority of this issue since it is not critical for the 3.1.1 release. Also, the current functionality of configure-jms-cluster command and the issue being reported here is by design. This is more of a RFE request. We can look at improving this functionality in a future release.

        David Zhao added a comment -

        Fixed.

        Check instances running.
        Revise warning message if there are instances running.


          People

          • Assignee:
            David Zhao
            Reporter:
            mathim
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: