glassfish
  1. glassfish
  2. GLASSFISH-15743

Admin GUI crashes when cookies are blocked

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1_b40
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Firefox 3.6.13, Mac OS, Java 1.6.0_22

      Description

      I went to http://localhost:4848/ and I got a completely un-helpful error message (stack trace from the log is below). I finally figured out what the cause was: I accidentally set Firefox to block cookies from localhost.

      I obviously don't expect the admin app to function without cookies, but it would be nice if it could fail cleanly and tell the user what the problem is.

      WARNING: StandardWrapperValve[FacesServlet]: PWC1406: Servlet.service() for servlet FacesServlet threw exception
      java.lang.IllegalStateException
      at org.apache.catalina.connector.ResponseFacade.sendError(ResponseFacade.java:486)
      at com.sun.faces.context.ExternalContextImpl.responseSendError(ExternalContextImpl.java:831)
      at com.sun.faces.application.view.MultiViewHandler.send404Error(MultiViewHandler.java:666)
      at com.sun.faces.application.view.MultiViewHandler.derivePhysicalViewId(MultiViewHandler.java:496)
      at com.sun.faces.application.view.MultiViewHandler.createView(MultiViewHandler.java:160)
      at com.sun.jsftemplating.layout.LayoutViewHandler.createView(LayoutViewHandler.java:221)
      at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:253)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      at com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:110)
      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:312)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1523)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:343)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:233)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:256)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:215)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:277)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:641)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:97)
      at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:85)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:185)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:325)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:226)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:239)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:170)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:680)

        Activity

        Anissa Lam added a comment -

        I am running on Mac 10.5.8,

        java version "1.6.0_22"
        Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-9M3263)
        Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)

        Google Chrome: 8.0.552.237
        Firefox 3.6.13
        Safari 5.0.3

        I have tried on all three browser above. remove all cookie, disable cookie, restart server and launch GUI.
        server.log says console is loaded.

        [#|2011-01-28T16:20:13.934-0800|INFO|glassfish3.1|javax.enterprise.system.core.com.sun.enterprise.v3.server|_ThreadID=85;_ThreadName=Thread-39;|CORE10010: Loading application __admingui done in 25,236 ms|#]

        [#|2011-01-28T16:20:13.936-0800|INFO|glassfish3.1|javax.enterprise.system.core.com.sun.enterprise.v3.admin.adapter|_ThreadID=85;_ThreadName=Thread-39;|The Admin Console application is loaded.|#]

        Browser tries to go to login screen, but cannot show it and getting blank screen instead.
        I didn't see any stack trace.

        Since there is no more stack trace that you mention in 3.1, I am marking this as resolved in 3.1


          People

          • Assignee:
            Anissa Lam
            Reporter:
            mike_baranczak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: