glassfish
  1. glassfish
  2. GLASSFISH-15759

HTTP Status 500 Error when orb-listener-1/SSL tab is clicked

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_dev
    • Fix Version/s: 3.1_dev
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS: SOlaris SParc 10
      Browser: firefox 3.6

      Description

      Build used : promoted b40.

      Click on server-config/ORB/iiop Listeners/orb-listener-1/SSL tab.
      The below HTTP Status 500 error is shown in browser.

      HTTP Status 500 -

      type Exception report

      message

      descriptionThe server encountered an internal error () that prevented it from fulfilling this request.

      exception

      javax.servlet.ServletException: java.lang.RuntimeException while attempting to process a 'beforeCreate' event for 'event156'.

      root cause

      java.lang.RuntimeException: java.lang.RuntimeException while attempting to process a 'beforeCreate' event for 'event156'.

      root cause

      java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while attempting to process a 'beforeCreate' event for 'event156'.

      root cause

      java.lang.reflect.InvocationTargetException

      root cause

      java.lang.NullPointerException

      note The full stack traces of the exception and its root causes are available in the Oracle GlassFish Server 3.1 logs.
      Oracle GlassFish Server 3.1

      Attached server.log

        Activity

        shaline added a comment -

        Same Error appears for a new iiop listener also, when the SSL tab is clicked for the new iiop listener.
        Create a new iiop listener and provide network address and listener port. Check Listener Enabled and Security. Click Save. Select the created Listener and click on SSL tab. we see the above Error.

        srinik76 added a comment -

        1. How bad is its impact? (Severity)
        Cannot access SSL Page

        2. How often does it happen? (Frequency)
        everytime when trying to access the ssl page

        3. How much effort is required to fix it? (Cost)
        3 hrs

        4. What is the risk of fixing it? (Risk)
        Small.

        5. Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No.

        6. If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        No. don't think it helps just telling user they cannot access the SSL page in GUI, when they have alredy realize that.

        7. How long has the bug existed in the product?
        Do not know the timeline, when the ssl element under orb-listener was removed to not be available by default and to be available only by accessing create-ssl

        8. Do regression tests exist for this issue?
        No. SSL Page access need to be added in the IiopListenerTest

        9. Which tests should QA (re)run to validate the fix did not destabilize GlassFish?
        Need to run IiopListenerTest under admingui/devtests

        10. When will a tested fix be ready for integration?
        It is ready now.

        srinik76 added a comment -

        Attaching the diff

        Index: corba/src/main/resources/sslEdit.jsf
        ===================================================================
        — corba/src/main/resources/sslEdit.jsf (revision 44793)
        +++ corba/src/main/resources/sslEdit.jsf (working copy)
        @@ -62,6 +62,10 @@
        setPageSessionAttribute(key="childType" value="ssl")
        setPageSessionAttribute(key="selfUrl", value="#

        {pageSession.parentUrl}/#{pageSession.childType}");
        setPageSessionAttribute(key="showCancelButton" value="#{true}" )
        + setPageSessionAttribute(key="createSslUrl", value="#{pageSession.parentUrl}

        /create-ssl");
        + createMap(result="#

        {pageSession.valueMap}");
        + mapPut(map="#{pageSession.valueMap}

        " key="target" value="#

        {pageSession.configName}

        ");
        + mapPut(map="#

        {pageSession.valueMap}

        " key="certNickname" value="");
        #include "/common/shared/sslPrepare.inc"

        Anissa Lam added a comment -

        The change looks fine. I have also rebuild based on this change and see that it fixes this issue.

        srinik76 added a comment -

        Checked in into the trunk.

        Issue : 15759, HTTP Status 500 Error when orb-listener-1/SSL tab is clicked
        Approved by: Nazrul, Reviewed by : Anissa

        Sending resources/sslEdit.jsf
        Transmitting file data .
        Committed revision 44804.

        srinik76 added a comment -

        Checked into the 3.1 branch

        Sending resources/sslEdit.jsf
        Transmitting file data .
        Committed revision 44805.

        Issue : 15759, HTTP Status 500 Error when orb-listener-1/SSL tab is clicked
        Approved by: Nazrul, Reviewed by : Anissa

        srinik76 added a comment -

        Branch 3.1 URL -> branches/3.1/admingui/corba/src/main/resources/sslEdit.jsf

        trunk URL -> trunk/v3/admingui/corba/src/main/resources/sslEdit.jsf


          People

          • Assignee:
            srinik76
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: