glassfish
  1. glassfish
  2. GLASSFISH-15766

Tree nodes Title page has Sun Logo before the node name.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b40
    • Fix Version/s: 3.1_b41
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS: Windows 2008 Server.
      Browser: IE 7.

      Description

      GF build used : promoted b40.

      In the adminConsole , when we click on the tree nodes , Common Tasks, Domain, Server etc, the Page Title displayed on the Left Top corner of the browser has the Logo "Sun" before the tree node name .
      It shows up for all the tree nodes in the left tree.
      and also appears before the URL http://hostname:4848

      Attached the screen shot.
      Notice the Sun Logo before "Common Tasks", and also in the URL field.

      1. console.bmp
        3.66 MB
      2. Firefox.jpg
        149 kB
      3. IE.jpg
        121 kB
      4. ogs-chrome.jpg
        127 kB

        Activity

        Anissa Lam added a comment -

        This is new to me. I have never seen this 'Sun' logo, It doesn't even exist in our workspace.

        We have been using the GlassFish favicon for many release, haven't changed that.
        I tried Firefox, chrome, IE, Safari, for both the open source brand and the oracle brand. Refer to the attached images. I cannot reproduce this.

        This is probably something in your environment. Can you try other browser ? or restart the browser, clear cache etc.

        We don't even have such an icon in our workspace. Not much i can do. closing as will not fix.

        Anissa Lam added a comment -

        Closing as cannot reproduce.

        shaline added a comment -

        I see the blue Sun Logo on all browsers using promoted b40. (latest-og-windows.exe, and latest-ogs.zip) bundles on Sparc and Windows 2008.

        Machines which has these installations can be accessed as below to see the Sun Logo.
        http://bigapp-oblade-3.us.oracle.com:4848 (windows 2008)
        http://cub-s10-2.us.oracle.com:4848 (Sparc)

        Snjezana Sevo-Zenzerovic added a comment -

        FWIW, this seems to be admingui/customtheme/src/main/resources/images/favicon.ico from internal workspace...

        Anissa Lam added a comment -

        Thanks Snjezana, thats correct.

        How bad is its impact? (Severity)
        Doesn't affect function, but we shouldn't be showing sun icon.

        How often does it happen? (Frequency)
        On every page.

        How much effort is required to fix it? (Cost)
        Very little

        What is the risk of fixing it? (Risk)
        Very little

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        No.

        • How long has the bug existed in the product?
          This icon has been used for Sun branded server fore 3.0.1. So, since day 1 for 3.1
        • Do regression tests exist for this issue?
          No.
        • Which tests should QA (re)run to validate the fix did not destabilize GlassFish?
          Just by observing, i guess.
        • When will a tested fix be ready for integration? (We know this)
          It is ready now.
        Chris Kasso added a comment -

        Approved for RC2.

        Anissa Lam added a comment -

        The oracle favicon.ico has been checked into both trunk and branch 3.1 in the internal workspace.

        Trunk version: # 2159
        Branch version: # 2160

        ============

        svn commit
        Sending admingui/customtheme/src/main/resources/images/favicon.ico
        Transmitting file data .
        Committed revision 2160.

        shaline added a comment -

        Verified in b42 nightly dated 02-09-11


          People

          • Assignee:
            Anissa Lam
            Reporter:
            shaline
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: