glassfish
  1. glassfish
  2. GLASSFISH-15782

Install summary HTML file shows many broken links

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1_b40
    • Fix Version/s: 3.1_b41
    • Component/s: installation
    • Labels:
      None

      Description

      This was discussed in GLASSFISH-15663 which has been resolved and not related to installation summary HTML file.

      Opening this to better keep track of the issue.

      From stephanj:
      >>The glassfish install summary HTML file shows many links to http://docs.sun.com/doc/820-7690 which are broken.

      From scatari:
      >>Paul,
      >> Can u provide us with the updated URL for Install Guide(online)? Are we not setting redirects for these links?

        Activity

        scatari added a comment -

        If the URL forwarding is setup appropriately, then no code changes are required.

        Paul Davies added a comment -

        URL forwarding is set up to re-direct all URLs to docs.sun.com to the main Oracle documentation page, which is why all such URLs now appear broken.

        The URL to the Installation Guide is:
        http://www.oracle.com/pls/topic/lookup?ctx=821-2427&id=sjsaseeig

        This link will return error 404 until the product ships.

        scatari added a comment -

        How bad is its impact? (Severity)

        Bad user experience as the user is not directed to the correct installation guide.

        How often does it happen? (Frequency)
        Every time

        How much effort is required to fix it? (Cost)
        0.5 engineering day.

        What is the risk of fixing it? (Risk)
        Nothing

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No workaround exists, but users could always be instructed to navigate to the correct URL documented
        in the Release Notes.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        Yes, please see above.

        How long has the bug existed in the product?
        From the beginning of 3.1 Release.

        Do regression tests exist for this issue?
        No, but the changes are very local.Also please see below.

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        A successful installation followed by start/stop server and uninstallation.

        When will a tested fix be ready for integration?
        02/02/2010.

        Chris Kasso added a comment -

        Approved for RC2.

        scatari added a comment -

        Reviewed by: Snjezana
        Approved by: Chris

        Checkin info for Trunk
        ------------------------------
        Sending src/GlassFishV3Preview/resources/view/Summary.xml
        Sending src/GlassFishV3WebProfilePreview/resources/view/Summary.xml
        Sending src/main/java/org/openinstaller/provider/conf/InstallationConfigurator.java
        Transmitting file data ...
        Committed revision 44839.

        Checkin info for Branch
        --------------------------------
        Sending src/GlassFishV3Preview/resources/view/Summary.xml
        Sending src/GlassFishV3WebProfilePreview/resources/view/Summary.xml
        Sending src/main/java/org/openinstaller/provider/conf/InstallationConfigurator.java
        Transmitting file data ...
        Committed revision 44844.


          People

          • Assignee:
            scatari
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: