glassfish
  1. glassfish
  2. GLASSFISH-15790

deleting an administered resource does not cause removal of corresponding osgi service

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1_b40
    • Fix Version/s: 3.1_b41
    • Component/s: OSGi-JavaEE
    • Labels:
      None

      Description

      When I delete a jdbc or jms resource, I don't see the corresponding osgi service getting unregistered. This is a regression. The fix has been discussed with Jagadish and it is trivial with zero side effect. So, we should fix this in 3.1 release itself.

        Activity

        Jagadish added a comment -

        How bad is its impact? (Severity)
        Identify why the fix needs to occur now:

        • Is a regression of functionality or performance available in a prior release
        • An in-your-face issue that will touch the majority of users

        How often does it happen? (Frequency)

        • We expose jdbc, jms resources as OSGi service references and when the underlying resource is deleted in GlassFish, they are not removed from OSGi service references. So, any OSGi bundle that uses these service references will face stale resource issue.

        How much effort is required to fix it? (Cost)

        • Minor, made sure that only one instance of resource-manager per type (jdbc, jms) is available at runtime.

        What is the risk of fixing it? (Risk)

        • Very minimal, fix is localized to OSGi-ee-resources module (does not affect GlassFish's core container modules)
        • Will make sure that QL (Web, Classic), connector-dev, jdbc-dev, connector-standalone-cts (Web, Classic), resources-admin-cli, connector-sqe-tests pass.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?

        • No.

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?

        • NA

        How long has the bug existed in the product?

        • 3-4 months (a regression).

        Do regression tests exist for this issue?

        • Yes, will be adding a new test-case for this use-case.

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        • NA

        When will a tested fix be ready for integration?

        • < 1 day's time.
        Sanjeeb Sahoo added a comment -

        Jagadish had sent me the patch for review and I do agree with him that this is a very very simple and localised fix and won't affect any part of Java EE container. It only addresses the bug found in osgi-ee-resources module.

        Jagadish added a comment -

        Added the following test-case to test jdbc and jms resources :
        trunk/v2/appserv-tests/devtests/connector/v3/osgi-resources-test

        http://java.net/projects/glassfish/sources/svn/show/trunk/v2/appserv-tests/devtests/connector/v3/osgi-resources-test?rev=44855

        Chris Kasso added a comment -

        Approved for RC2.

        Jagadish added a comment -

        svn log -v -r 44868
        Modified Paths:
        ---------------
        branches/3.1/osgi-javaee/osgi-ee-resources/src/main/java/org/glassfish/osgi/ee/resources/ResourceProviderService.java

        svn log -v -r 44870
        Modified Paths:
        ---------------
        trunk/v3/osgi-javaee/osgi-ee-resources/src/main/java/org/glassfish/osgi/ee/resources/ResourceProviderService.java


          People

          • Assignee:
            Jagadish
            Reporter:
            Sanjeeb Sahoo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved: