glassfish
  1. glassfish
  2. GLASSFISH-15820

start-local-instance prompts for master password even though save-master-password is used

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None

      Description

      Carla was trying to verify one of her bugs 14850 and ran into this issue.
      Here is the gist of the issue from Carla's email.
      "
      On DAS machine:

      create a domain with the master-password set to "welcome1" using the command
      asadmin create-domain --savemasterpassword true --passwordfile ~/passfile3 domain2

      create an ssh node using
      asadmin create-node-ssh --nodehost adc2190111 --installdir /scratch/gf/cmott/glassfish3 node2

      create an instance (on instance machine). This works fine

      asadmin create-instance --node node2 ins2

      If I try to start ins2 I get an error which I expected.

      On the instance machine I try to set the master password.
      asadmin change-master-password --savemasterpassword true --nodedir /scratch/gf/cmott/glassfish3/glassfish/nodes node2

      This seems to set the master-password and creates a file called master-password in the agent dir of the node node2

      Now I see the following:

      on the DAS if I try to start the instance using

      asadmin start-instance ins2
      I get a failure

      on the instance machine if I try to start the instance using

      asadmin start-local-instance ins2

      I am prompted for the master password and it will start once that is supplied.

      If I create a new instance on the instance machine using

      asadmin create-local-instance --usemasterpassword true --host dhcp-santaclara22-1fl-west-10-132-181-59.usdhcp.oraclecorp.com --node node2 ins3

      I am prompted for the master password and the instance is created.

      If I try to start the instance using start-local-instance I am also prompted for the master password. asadmin start-local-instance ins3

      I can't seem to start the instance without providing the master password as the instance is starting. This means that the user will not be able to administer the instances from a central location.
      I thought that we should be able to start the instances without prompting if the master passwords were the same on both instance and the DAS. What am I missing?"

        Activity

        Bhakti Mehta added a comment -

        How bad is its impact? (Severity)

        This is an in-your-face issue that will touch the majority of users

        How often does it happen? (Frequency)
        This will happen all the time when master password is used with start-local-instance

        How much effort is required to fix it? (Cost)
        Less effort I have a patch and am trying all cases right now

        What is the risk of fixing it? (Risk)
        Minor risk.

        Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        There is no workaround other than entering the master password when instance is starting. If possible I would really like to fix this regression I introduced with my commit 44449

        If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        It would be preferable to fix this issue

        How long has the bug existed in the product?
        From Jan 12 2011

        Do regression tests exist for this issue?
        Yes I will run my tests and also have requested Carla to verify my fix

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        I dont think QA runs tests with master password. Will check with them

        When will a tested fix be ready for integration?
        Feb4

        Nazrul added a comment -

        Approved for checkin pending review from Tom/Joe.

        Bhakti Mehta added a comment -

        Committed on trunk and branch

        Sending admin/cli/src/main/java/com/sun/enterprise/admin/cli/LocalServerCommand.java
        Sending cluster/cli/src/main/java/com/sun/enterprise/admin/cli/cluster/LocalInstanceCommand.java
        Transmitting file data ..
        Committed revision 44908.

        Sending admin/cli/src/main/java/com/sun/enterprise/admin/cli/LocalServerCommand.java
        Sending cluster/cli/src/main/java/com/sun/enterprise/admin/cli/cluster/LocalInstanceCommand.java
        Transmitting file data ..
        Committed revision 44907.


          People

          • Assignee:
            Bhakti Mehta
            Reporter:
            Bhakti Mehta
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: