Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1_b40
    • Fix Version/s: 3.1_b42
    • Component/s: admin
    • Labels:
      None

      Description

      The localized man pages are not loaded for some locales. The l10n man pages are provided in the following directory structure:
      <top level dir>/lang_country_variant
      the function getLocaleLocations in CLIManFinder.java is using "/" instead of "_" in the lookup

        Activity

        Tom Mueller added a comment -

        Fixed on the trunk in revision 44964.
        Waiting to mark this resolved until it is determined whether this needs to be fixed in 3.1.

        Tom Mueller added a comment - - edited

        1. How bad is its impact? (Severity)

        Is a regression of functionality or performance available in a prior release
        Likely to generate a customer support call

        2. How often does it happen? (Frequency)
        This would happen for users that retrieve manual pages from asadmin in the following locales:
        zh_TW, zh_CH, and pt_BR

        3. How much effort is required to fix it? (Cost)
        Very low. The change is already checked into the trunk. It just needs to be reviewed by another developer
        and checked into the 3.1 branch.
        4. What is the risk of fixing it? (Risk)
        Very low.

        5. Does a work around for the issue exist? Can the workaround be reasonably employed by the end user?
        No, short of the user extracting the manual page from the JAR file using the jar command.

        6. If the issue is not fixed should the issue and its workaround (if applicable) be described in the Release Notes?
        No

        7. How long has the bug existed in the product?
        At least since July 2009 when this file was introduced to SVN. I expect it has always existed in 3.0. However, since manual pages were not translated before, the bug didn't show up.

        8. Do regression tests exist for this issue?
        No.

        9. Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        Use asadmin to retrieve manual pages for default locale and the effected locales.

        10. When will a tested fix be ready for integration?
        Afternoon of Feb 7.

        Nazrul added a comment -

        Approved for checkin into RC3.

        Tom Mueller added a comment -

        Fixed in 3.1 branch revision 44968.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            gmurr
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: